# Apache returns 404 " /setup/install/e7bbc5ac... was not found on this server." after installing Passbolt V2

**URL:** <https://community.passbolt.com/t/apache-returns-404-setup-install-e7bbc5ac-was-not-found-on-this-server-after-installing-passbolt-v2/602>\
**Category:** Installation Issues\
**Created:** [April 23, 2018, 2:00pm UTC](https://community.passbolt.com/t/apache-returns-404-setup-install-e7bbc5ac-was-not-found-on-this-server-after-installing-passbolt-v2/602 "2018-04-23T14:00:04Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![Miodragl](https://avatars.discourse-cdn.com/v4/letter/m/76d3ee/32.png) [@Miodragl](https://community.passbolt.com/u/Miodragl)\
**Post date:** [April 23, 2018, 2:00pm UTC](https://community.passbolt.com/t/apache-returns-404-setup-install-e7bbc5ac-was-not-found-on-this-server-after-installing-passbolt-v2/602/1 "2018-04-23T14:00:05Z")

</div>

I set up Passbolt behind Nginx proxy, i configured domain with letsencrypt on proxy server and I am able  
to access Apache welcome page with **[http://mydomain/passbolt](http://mydomain/passbolt)**, but when i installed passbolt successfully and tried to access the link that i get at the end of installation, Apache returns **ERROR 404** from the title above:  
**" /setup/install/e7bbc5ac… was not found on this server."**

in passbolt.php file my url looks like this:

```
'App' => [
    // A base URL to use for absolute links.
    // The url where the passbolt instance will be reachable to your end users.
    // This information is need to render images in emails for example
    'fullBaseUrl' => 'http://my_domain/passbolt'

```

Anyone has an idea?

Thanks

---

<div class="post-metadata">

**Author:** ![remy](https://yyz1.discourse-cdn.com/flex031/user_avatar/community.passbolt.com/remy/32/17_2.png) [@remy](https://community.passbolt.com/u/remy)\
**Post date:** [April 24, 2018, 10:07am UTC](https://community.passbolt.com/t/apache-returns-404-setup-install-e7bbc5ac-was-not-found-on-this-server-after-installing-passbolt-v2/602/2 "2018-04-24T10:07:13Z")

</div>

If you are running passbolt in a directory you should not add the directory in the fullBaseUrl, it will be detected automatically.

---

<div class="post-metadata">

**Author:** ![Miodragl](https://avatars.discourse-cdn.com/v4/letter/m/76d3ee/32.png) [@Miodragl](https://community.passbolt.com/u/Miodragl)\
**Post date:** [April 24, 2018, 11:30am UTC](https://community.passbolt.com/t/apache-returns-404-setup-install-e7bbc5ac-was-not-found-on-this-server-after-installing-passbolt-v2/602/3 "2018-04-24T11:30:07Z")

</div>

@remy Ok, i changed that in the meantime, but now when i enter username and password, it gets stuck on  
"Loading, please wait… “, when i go rightclick + inspect, i get : Failed to load resource: the server responded with a status of 404 (Not Found)” and the critical js file is **steal.production.js**

---

<div class="post-metadata">

**Author:** ![remy](https://yyz1.discourse-cdn.com/flex031/user_avatar/community.passbolt.com/remy/32/17_2.png) [@remy](https://community.passbolt.com/u/remy)\
**Post date:** [April 24, 2018, 11:45am UTC](https://community.passbolt.com/t/apache-returns-404-setup-install-e7bbc5ac-was-not-found-on-this-server-after-installing-passbolt-v2/602/4 "2018-04-24T11:45:36Z")

</div>

Hi @Miodragl,

I’m not sure what’s wrong with your setup, but I just tested running the v2.0.3 in a subdirectory with apache rewriting enabled at the top level and it worked (with fullBaseUrl set to www.passbolt.test). See apache config bellow:

Apache config:

```auto
<IfModule mod_ssl.c>
        <VirtualHost _default_:443>
                ServerAdmin webmaster@localhost
                ServerName www.passbolt.test
                DocumentRoot /var/www

                ErrorLog ${APACHE_LOG_DIR}/error.log
                CustomLog ${APACHE_LOG_DIR}/access.log combined

                SSLEngine on
                SSLCertificateFile /etc/apache2/ssl/passbolt.crt
                SSLCertificateKeyFile /etc/apache2/ssl/passbolt.key

                <FilesMatch "\.(cgi|shtml|phtml|php)$">
                                SSLOptions +StdEnvVars
                </FilesMatch>
                <Directory /usr/lib/cgi-bin>
                                SSLOptions +StdEnvVars
                </Directory>

        <Directory /var/www>
            Options FollowSymLinks
            AllowOverride All
            Require all granted
        </Directory>

        </VirtualHost>
</IfModule>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

```

 ![12](https://canada1.discourse-cdn.com/flex031/uploads/passbolt/original/1X/5d4ae98a9adc33463f39c0fb712f5ff2f28a4dc7.png)

---

<div class="post-metadata">

**Author:** ![Miodragl](https://avatars.discourse-cdn.com/v4/letter/m/76d3ee/32.png) [@Miodragl](https://community.passbolt.com/u/Miodragl)\
**Post date:** [April 24, 2018, 11:46am UTC](https://community.passbolt.com/t/apache-returns-404-setup-install-e7bbc5ac-was-not-found-on-this-server-after-installing-passbolt-v2/602/5 "2018-04-24T11:46:56Z")

</div>

@remy can i do this somehow without ssl with port 80 ?

---

<div class="post-metadata">

**Author:** ![remy](https://yyz1.discourse-cdn.com/flex031/user_avatar/community.passbolt.com/remy/32/17_2.png) [@remy](https://community.passbolt.com/u/remy)\
**Post date:** [April 24, 2018, 11:48am UTC](https://community.passbolt.com/t/apache-returns-404-setup-install-e7bbc5ac-was-not-found-on-this-server-after-installing-passbolt-v2/602/6 "2018-04-24T11:48:09Z")

</div>

Most likely it works without SSL, as long as URL rewriting is enabled. See. [https://book.cakephp.org/3.0/en/installation.html](https://book.cakephp.org/3.0/en/installation.html) for more information.

---

<div class="post-metadata">

**Author:** ![Miodragl](https://avatars.discourse-cdn.com/v4/letter/m/76d3ee/32.png) [@Miodragl](https://community.passbolt.com/u/Miodragl)\
**Post date:** [April 24, 2018, 11:49am UTC](https://community.passbolt.com/t/apache-returns-404-setup-install-e7bbc5ac-was-not-found-on-this-server-after-installing-passbolt-v2/602/7 "2018-04-24T11:49:48Z")

</div>

can i send you my configuration ? i’ve already enable rewrite module, but still doesn’t work.

\<VirtualHost \*:80\>  
ServerAdmin webmaster@localhost  
ServerName passbolt

```
DocumentRoot /var/www/passbolt

ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

<Directory /var/www/passbolt>
    Options FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>

```

~

---

<div class="post-metadata">

**Author:** ![remy](https://yyz1.discourse-cdn.com/flex031/user_avatar/community.passbolt.com/remy/32/17_2.png) [@remy](https://community.passbolt.com/u/remy)\
**Post date:** [April 24, 2018, 11:51am UTC](https://community.passbolt.com/t/apache-returns-404-setup-install-e7bbc5ac-was-not-found-on-this-server-after-installing-passbolt-v2/602/8 "2018-04-24T11:51:36Z")

</div>

I’m not sure how it work with /var/www/passbolt as DocumentRoot, you notice mine point to /var/www like you would get with hosting provider like GoDaddy or what not. You probably need to play around the config and the rewrite rules.

---

<div class="post-metadata">

**Author:** ![Miodragl](https://avatars.discourse-cdn.com/v4/letter/m/76d3ee/32.png) [@Miodragl](https://community.passbolt.com/u/Miodragl)\
**Post date:** [April 24, 2018, 12:10pm UTC](https://community.passbolt.com/t/apache-returns-404-setup-install-e7bbc5ac-was-not-found-on-this-server-after-installing-passbolt-v2/602/9 "2018-04-24T12:10:07Z")

</div>

@remy, when i set appurl to ‘https://my\_domain’ , it gets stuck on “loading, please wait”, but when i set appurl to  
“https://my\_domain/passbolt”, i loged sucessfully and my profile page looks just fine, but login page looks like this:

 ![image](https://canada1.discourse-cdn.com/flex031/uploads/passbolt/original/1X/92fd795ab85dbfc407a6cda71d915cd0bd6c9c54.png)

---

<div class="post-metadata">

**Author:** ![prakashriti](https://avatars.discourse-cdn.com/v4/letter/p/b19c9b/32.png) [@prakashriti](https://community.passbolt.com/u/prakashriti)\
**Post date:** [April 27, 2018, 5:43am UTC](https://community.passbolt.com/t/apache-returns-404-setup-install-e7bbc5ac-was-not-found-on-this-server-after-installing-passbolt-v2/602/10 "2018-04-27T05:43:20Z")

</div>

Hi @remy, i am new to passbolt and i just followed as per the documentation in this link [https://help.passbolt.com/hosting/install/ce/centos-7.html](https://help.passbolt.com/hosting/install/ce/centos-7.html)

when i perform `./bin/cake passbolt healthcheck` it shows me below 5 errors,

[FAIL] Could not reach the /healthcheck/status with the url specified in App.fullBaseUrl  
[FAIL] SSL peer certificate does not validate  
[FAIL] Hostname does not match when validating certificates.  
[FAIL] Passbot is not configured to force SSL use.  
[FAIL] App.fullBaseUrl is not set to HTTPS.

I am not sure how to solve these errors as i havent configured https. Also i am using nginx and am getting the 404 error when i try to register the passbolt.

Do i need to write any rewrite rule if i use apache or nginx? i dont find any information about this in the documentation too… Please guide me

---

<div class="post-metadata">

**Author:** ![system](https://canada1.discourse-cdn.com/flex031/uploads/passbolt/original/2X/b/bee7d3f9329f668000d46e9fcb2e5db1e9d31348.svg) [@system](https://community.passbolt.com/u/system)\
**Post date:** [May 2, 2018, 5:43am UTC](https://community.passbolt.com/t/apache-returns-404-setup-install-e7bbc5ac-was-not-found-on-this-server-after-installing-passbolt-v2/602/11 "2018-05-02T05:43:43Z")

</div>

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.
