As a user I should be able to disable the in-form menu in the settings

Hello everyone,

I would like to ask if it is possible to turn off the extension icon that appears when you hover over some input (as seen below).
image

For us it appears on inputs that are not connected to passwords at all and it is annoying when trying to click and you select passbolt instead.
Another reason is that it is bothering our sales staff while doing presentations of our app.

At the moment we are using a workaround by opening a private browser window with disabled extensions but I was wandering if there is another solution to this problem.

Thanks in advance for any feedback.

1 Like

Hello @Salient ,

It is possible for a server administrator to disable the plugin responsible for this feature by setting the PASSBOLT_PLUGINS_IN_FORM_INTEGRATION_ENABLED environment variable to false (if you use docker). Let us know if you need help with this.

Best,

Hey,

I strongly believe that this should be a client-sided choice. It seems odd that the server admin would have to disable this globally for all users, merely because it conflicts with some users’ setup / preferences.

As-is it happens to not be usable, as it also overlaps with my primary password manager’s in-form icon.

1 Like

Hi @morrolan,

I agree there should be a user setting to control this, unfortunately this is not the case at the moment. I changed the category / title of your post to reflect this.

Best,

1 Like

Hello @remy ,

We managed to disable the feature according to your advise, thanks a lot for your help!

Regards,

Yes, please please add a client-side user setting to disable the in-form menu. I have no need for it, and it interferes with website UI.

A server / organisation wide setting is not enough: some users may like it, while others won’t.

I would remove the browser extension because of this if I could, but of course with Passbolt, the extension is required for basic access as well.

If you are open to such a feature being contributed, please let me know.

For the moment, I have downgraded my add-on version to 3.2.3 to avoid the in-form menu, but this is obviously not ideal for security-focused software.

I would also like to see this functionality added. Please!

1 Like

Hello @remy

Using the passbolt on a standard (non-docker) installation, I tried to find out which parameter is overridden by the PASSBOLT_PLUGINS_IN_FORM_INTEGRATION_ENABLED variable.
However, I did not find it by searching for “full text” or in the Passbolt documentation (this variable not being referenced in “Environment variables reference” on GitHub - passbolt/passbolt_docker: Get started with Passbolt CE using docker!).
Do you have any suggestions to continue my investigation?

@sklaxs In the passbolt_api repo you will find where it is used here: passbolt_api/config.php at master · passbolt/passbolt_api · GitHub

Hi,

As “in-form integration” is a passbolt plugin, the proper way to disable it is to add a “plugin” section inside the passbolt section, in /etc/passbolt/passbolt.php configuration file.

Like this:

(...)
    'passbolt' => [
        'plugins' => [
          'inFormIntegration' => [
             'enabled' => false
           ]
        ],
        // GPG Configuration.
        // The keyring must to be owned and accessible by the webserver user.
        // Example: www-data user on Debian
        'gpg' => [
(...)

Once done, log out from passbolt to apply this.

Cheers,

@garrett, @_jc, thank you for your answers, the _jc solution works.

2 Likes

+1

As an alternative to completely disabling the in-form menu, it might be even better to be able to change the position of the icon (i.e. at the left side of the input field). This way passbolt could be used alongside any other password manager.