# Blank Page - New Install on Synology Nas Docker

**URL:** https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493
**Category:** Installation Issues
**Created:** [February 8, 2023, 2:47am UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493 "2023-02-08T02:47:07Z")
**Posts on this page:** 18
**Page:** 2

<div class="post-metadata">

### Author: ![garrett](https://yyz1.discourse-cdn.com/flex031/user_avatar/community.passbolt.com/garrett/32/545_2.png) [@garrett](https://community.passbolt.com/u/garrett)
#### Post date: [February 14, 2023, 6:56pm UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493/21 "2023-02-14T18:56:23Z")

</div>

Thanks for taking the time @mariushosting

---

<div class="post-metadata">

### Author: ![AnatomicJC](https://yyz1.discourse-cdn.com/flex031/user_avatar/community.passbolt.com/anatomicjc/32/962_2.png) [@AnatomicJC](https://community.passbolt.com/u/AnatomicJC)
#### Post date: [February 14, 2023, 8:11pm UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493/22 "2023-02-14T20:11:17Z")

</div>

Thanks Marius also for your great tutorial 👍

---

<div class="post-metadata">

### Author: ![Yohan](https://yyz1.discourse-cdn.com/flex031/user_avatar/community.passbolt.com/yohan/32/1749_2.png) [@Yohan](https://community.passbolt.com/u/Yohan)
#### Post date: [February 15, 2023, 5:13am UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493/23 "2023-02-15T05:13:52Z")

</div>

I have active web socket at STEP 7.

![2023-02-15-14-05-05](https://canada1.discourse-cdn.com/flex031/uploads/passbolt/original/2X/3/3ae24cdb1886051c090e6c4bf8d208cecb9b03c5.png)

To make sure I delete and create web socket again.  
Checking other steps again too

![2023-02-15-14-07-51](https://canada1.discourse-cdn.com/flex031/uploads/passbolt/original/2X/9/93b25bd128412cb5f04fb11299135abeb6dd8986.png)

 ![2023-02-15-14-08-04](https://canada1.discourse-cdn.com/flex031/uploads/passbolt/original/2X/a/a1404d165eade80f2abceb05c058e10bf44089ef.png)

 ![2023-02-15-14-08-42](https://canada1.discourse-cdn.com/flex031/uploads/passbolt/original/2X/6/6bae61450d1cd6c857beb62aedba18d3bb2839ed.png)

 ![2023-02-15-14-10-52](https://canada1.discourse-cdn.com/flex031/uploads/passbolt/original/2X/3/31ea63eb6e67f3ba79409b1f70c186fb67bd4e5f.png)

I found db folder permission is Read only (jwt and gpg folders permission are everyone read and write)  
I type SMTP info as not gmail. (typed other SMTP info)

Still getting blank page with Passbolt text on header

@mariushosting Thank you for your awesome guide and support! I have installed other app on my nas thanks to your guide. I just sent 33 Euro donation to you 🙂

---

<div class="post-metadata">

### Author: ![mariushosting](https://yyz1.discourse-cdn.com/flex031/user_avatar/community.passbolt.com/mariushosting/32/1775_2.png) [@mariushosting](https://community.passbolt.com/u/mariushosting)
#### Post date: [February 15, 2023, 5:27am UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493/24 "2023-02-15T05:27:45Z")

</div>

Looks like cache. Please follow this guide: [Synology: How to Clean Docker – Marius Hosting](https://mariushosting.com/synology-how-to-clean-docker/) and delete passbolt

After that reinstall it from scratch. This will solve the issue for sure.

Marius

---

<div class="post-metadata">

### Author: ![luckyearl](https://avatars.discourse-cdn.com/v4/letter/l/b5e925/32.png) [@luckyearl](https://community.passbolt.com/u/luckyearl)
#### Post date: [March 2, 2023, 1:12pm UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493/25 "2023-03-02T13:12:59Z")

</div>

I have installed Passbolt on Synology using @mariushosting 's guide  
Unable to setup account  
error

`Access to this service requires an invitation. This email is not associated with any approved users on this domain. Please contact your administrator to request an invitation link.`  
Try another email

Please advise  
Thank you

---

<div class="post-metadata">

### Author: ![mariushosting](https://yyz1.discourse-cdn.com/flex031/user_avatar/community.passbolt.com/mariushosting/32/1775_2.png) [@mariushosting](https://community.passbolt.com/u/mariushosting)
#### Post date: [March 2, 2023, 1:26pm UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493/26 "2023-03-02T13:26:07Z")

</div>

Reinstall from scratch or update your stack  
You forget to add email in the compose.

---

<div class="post-metadata">

### Author: ![luckyearl](https://avatars.discourse-cdn.com/v4/letter/l/b5e925/32.png) [@luckyearl](https://community.passbolt.com/u/luckyearl)
#### Post date: [March 2, 2023, 1:30pm UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493/27 "2023-03-02T13:30:14Z")

</div>

Thanks Marius

Part of my compose , anywhere I have missed?, plz advise. Thank you

```auto
DEBUG: false
      APP_FULL_BASE_URL: https://passbolt.myID.synology.me
      DATASOURCES_DEFAULT_HOST: passbolt-db
      DATASOURCES_DEFAULT_USERNAME: passboltuser
      DATASOURCES_DEFAULT_PASSWORD: passboltpass
      DATASOURCES_DEFAULT_DATABASE: passbolt
      PASSBOLT_REGISTRATION_PUBLIC: true
      EMAIL_DEFAULT_FROM: luckyearl122@gmail.com
      EMAIL_TRANSPORT_DEFAULT_HOST: smtp.gmail.com
      EMAIL_TRANSPORT_DEFAULT_PORT: 587
      EMAIL_TRANSPORT_DEFAULT_USERNAME: luckyearl122@gmail.com
      EMAIL_TRANSPORT_DEFAULT_PASSWORD: xxxxxx
      EMAIL_TRANSPORT_DEFAULT_TLS: true

```

---

<div class="post-metadata">

### Author: ![luckyearl](https://avatars.discourse-cdn.com/v4/letter/l/b5e925/32.png) [@luckyearl](https://community.passbolt.com/u/luckyearl)
#### Post date: [March 2, 2023, 2:14pm UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493/28 "2023-03-02T14:14:37Z")

</div>

@mariushosting

Reinstalled from scratch, same error

any suggestions plz

Thank you

---

<div class="post-metadata">

### Author: ![luckyearl](https://avatars.discourse-cdn.com/v4/letter/l/b5e925/32.png) [@luckyearl](https://community.passbolt.com/u/luckyearl)
#### Post date: [March 2, 2023, 4:53pm UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493/29 "2023-03-02T16:53:16Z")

</div>

Health Check

```auto
[FAIL] The server OpenPGP key is not set
[FAIL] The server key fingerprint doesn't match the one defined in /etc/passbolt/passbolt.php.
[FAIL] The server public key defined in the /etc/passbolt/passbolt.php (or environment variables) is not in 
[FAIL] The server key does not have a valid email id.the keyring

```

Hi these are the errors on health Check, please suggest to remedy them

Thank you

log

```auto
______  ____  
    / __\____  _________ / /_ ____ / / /_ 
   / /_/ / __`/___ / ___/__ \/ __\/ /__ / 
  / ____/ /_/ (__ |__ ) /_/ / /_/ / / /    
 /_/ \ __,_/____ / ____/_.___ /\ ____/_/\__ /   

 Open source password manager for teams
-------------------------------------------------------------------------------
 Healthcheck shell         
-------------------------------------------------------------------------------

 Environment

 [PASS] PHP version 7.4.33.
 [PASS] PCRE compiled with unicode support.
 [PASS] The temporary directory and its content are writable and not executable.
 [PASS] The logs directory and its content are writable.
 [PASS] GD or Imagick extension is installed.
 [PASS] Intl extension is installed.
 [PASS] Mbstring extension is installed.

 Config files

 [PASS] The application config file is present
 [WARN] The passbolt config file is missing in /etc/passbolt/
 [HELP] Copy /etc/passbolt/passbolt.default.php to /etc/passbolt/passbolt.php
 [HELP] The passbolt config file is not required if passbolt is configured with environment variables

 Core config

 [PASS] Debug mode is off.
 [PASS] Cache is working.
 [PASS] Unique value set for security.salt
 [PASS] Full base url is set to https://passbolt.myDomain.synology.me
 [PASS] App.fullBaseUrl validation OK.
 [PASS] /healthcheck/status is reachable.

 SSL Certificate

 [PASS] SSL peer certificate validates
 [PASS] Hostname is matching in SSL certificate.
 [PASS] Not using a self-signed certificate

 Database

 [PASS] The application is able to connect to the database
 [PASS] 26 tables found
 [PASS] Some default content is present
 [PASS] The database schema up to date.

 GPG Configuration

 [PASS] PHP GPG Module is installed and loaded.
 [PASS] The environment variable GNUPGHOME is set to /var/lib/passbolt/.gnupg.
 [PASS] The directory /var/lib/passbolt/.gnupg containing the keyring is writable by the webserver user.
 [FAIL] The server OpenPGP key is not set
 [HELP] Create a key, export it and add the fingerprint to /etc/passbolt/passbolt.php
 [HELP] See. https://www.passbolt.com/help/tech/install#toc_gpg
 [PASS] The public key file is defined in /etc/passbolt/passbolt.php and readable.
 [PASS] The private key file is defined in /etc/passbolt/passbolt.php and readable.
 [FAIL] The server key fingerprint doesn't match the one defined in /etc/passbolt/passbolt.php.
 [HELP] Double check the key fingerprint, example: 
 [HELP] sudo su -s /bin/bash -c "gpg --list-keys --fingerprint --home /var/lib/passbolt/.gnupg" www-data | grep -i -B 2 'SERVER_KEY_EMAIL'
 [HELP] SERVER_KEY_EMAIL: The email you used when you generated the server key.
 [HELP] See. https://www.passbolt.com/help/tech/install#toc_gpg
 [FAIL] The server public key defined in the /etc/passbolt/passbolt.php (or environment variables) is not in the keyring
 [HELP] Import the private server key in the keyring of the webserver user.
 [HELP] you can try:
 [HELP] sudo su -s /bin/bash -c "gpg --home /var/lib/passbolt/.gnupg --import /etc/passbolt/gpg/serverkey_private.asc" www-data
 [FAIL] The server key does not have a valid email id.
 [HELP] Edit or generate another key with a valid email id.

 Application configuration

 [PASS] Using latest passbolt version (3.11.0).
 [PASS] Passbolt is configured to force SSL use.
 [PASS] App.fullBaseUrl is set to HTTPS.
 [PASS] Selenium API endpoints are disabled.
 [PASS] Search engine robots are told not to index content.
 [PASS] The Self Registration plugin is enabled.
 [PASS] Registration is closed, only administrators can add users.
 [PASS] The deprecated self registration public setting was not found in /etc/passbolt/passbolt.php.
 [WARN] Host availability checking is disabled.
 [HELP] Make sure this instance is not publicly available on the internet.
 [HELP] Or set the PASSBOLT_EMAIL_VALIDATE_MX environment variable to true.
 [HELP] Or set passbolt.email.validate.mx to true in /etc/passbolt/passbolt.php.
 [PASS] Serving the compiled version of the javascript app.
 [WARN] Some email notifications are disabled by the administrator.

 JWT Authentication

 [PASS] The JWT Authentication plugin is enabled
 [PASS] The /etc/passbolt/jwt/ directory is not writable.
 [PASS] A valid JWT key pair was found

 SMTP Settings

 [PASS] The SMTP Settings plugin is enabled.
 [PASS] SMTP Settings coherent. You may send a test email to validate them.
 [WARN] The SMTP Settings source is: env variables.
 [HELP] It is recommended to set the SMTP Settings in the database through the administration section.
 [WARN] The SMTP Settings plugin endpoints are enabled.
 [HELP] It is recommended to disable the plugin endpoints.
 [HELP] Set the PASSBOLT_SECURITY_SMTP_SETTINGS_ENDPOINTS_DISABLED environment variable to true.
 [HELP] Or set passbolt.security.smtpSettings.endpointsDisabled to true in /etc/passbolt/passbolt.php.

 [FAIL] 4 error(s) found. Hang in there!

```

---

<div class="post-metadata">

### Author: ![garrett](https://yyz1.discourse-cdn.com/flex031/user_avatar/community.passbolt.com/garrett/32/545_2.png) [@garrett](https://community.passbolt.com/u/garrett)
#### Post date: [March 2, 2023, 5:05pm UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493/30 "2023-03-02T17:05:47Z")

</div>

Hi @luckyearl The suggested remedies are listed on the `[HELP] ` lines in the healthcheck. Try those first, and post back if you have trouble.

---

<div class="post-metadata">

### Author: ![luckyearl](https://avatars.discourse-cdn.com/v4/letter/l/b5e925/32.png) [@luckyearl](https://community.passbolt.com/u/luckyearl)
#### Post date: [March 2, 2023, 5:08pm UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493/31 "2023-03-02T17:08:46Z")

</div>

Thanks @garrett  
Just managed to crack it  
For Someone who is looking for solution  
Portainer → Container → Console

```auto
.bin/cake passbolt register_user -u email -f name -l surname -r admin

```

This shud set the user  
Cheers

---

<div class="post-metadata">

### Author: ![luckyearl](https://avatars.discourse-cdn.com/v4/letter/l/b5e925/32.png) [@luckyearl](https://community.passbolt.com/u/luckyearl)
#### Post date: [March 2, 2023, 6:09pm UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493/32 "2023-03-02T18:09:02Z")

</div>

And for completion, this shud sort the gpg errors

```auto
export PASSBOLT_GPG_SERVER_KEY_FINGERPRINT="$(gpg \
  --home $GNUPGHOME\
  --list-keys \
  ${PASSBOLT_KEY_EMAIL:-passbolt@yourdomain.com} | \
  grep -Ev "^(pub|sub|uid|^$)" | tr -d ' ')"

```

---

<div class="post-metadata">

### Author: ![mariushosting](https://yyz1.discourse-cdn.com/flex031/user_avatar/community.passbolt.com/mariushosting/32/1775_2.png) [@mariushosting](https://community.passbolt.com/u/mariushosting)
#### Post date: [March 2, 2023, 8:31pm UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493/33 "2023-03-02T20:31:45Z")

</div>

I can-t replicate your issue in any of my 5 NAS devices, looks like The /etc/passbolt/jwt/ directory is not writable on your NAS this means you forget to add write permission to the folder. Btw, looks like I have an old version installed I will update it tonight.

---

<div class="post-metadata">

### Author: ![Yohan](https://yyz1.discourse-cdn.com/flex031/user_avatar/community.passbolt.com/yohan/32/1749_2.png) [@Yohan](https://community.passbolt.com/u/Yohan)
#### Post date: [March 3, 2023, 2:57am UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493/34 "2023-03-03T02:57:32Z")

</div>

I follow [Synology: How to Clean Docker – Marius Hosting](https://mariushosting.com/synology-how-to-clean-docker/)  
I remove images and other on portainer related passbolt and directories on file stations too.  
Then install from scratch. When I Click Deploy the stack on portainer, I get this error

Deployment error  
mkdir /data/compose no such file or directory  
 ![2023-03-03-11-57-01](https://canada1.discourse-cdn.com/flex031/uploads/passbolt/original/2X/7/72b180ac0f8f113009cbcce7860a4c0de5d30e93.png)

Thanks Marius!

---

<div class="post-metadata">

### Author: ![luckyearl](https://avatars.discourse-cdn.com/v4/letter/l/b5e925/32.png) [@luckyearl](https://community.passbolt.com/u/luckyearl)
#### Post date: [March 14, 2023, 1:43am UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493/35 "2023-03-14T01:43:29Z")

</div>

Hi Yohan  
did you create the db, gpg & jwt folders in passbolt folder?

---

<div class="post-metadata">

### Author: ![luckyearl](https://avatars.discourse-cdn.com/v4/letter/l/b5e925/32.png) [@luckyearl](https://community.passbolt.com/u/luckyearl)
#### Post date: [March 14, 2023, 2:10am UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493/36 "2023-03-14T02:10:37Z")

</div>

@mariushosting  
Thank you for updating your website with ninstructions to create first account  
Can I plz suggest to add instructions for

1. fixing PGP key errors
2. Connecting to mobile app

Thank you

---

<div class="post-metadata">

### Author: ![Yohan](https://yyz1.discourse-cdn.com/flex031/user_avatar/community.passbolt.com/yohan/32/1749_2.png) [@Yohan](https://community.passbolt.com/u/Yohan)
#### Post date: [March 14, 2023, 2:14am UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493/37 "2023-03-14T02:14:59Z")

</div>

Yes  
 ![2023-03-14-11-14-26](https://canada1.discourse-cdn.com/flex031/uploads/passbolt/original/2X/9/97bdd0893eb0f0ffb251347b93b4df11d1048b71.png)

---

<div class="post-metadata">

### Author: ![ivanswip](https://yyz1.discourse-cdn.com/flex031/user_avatar/community.passbolt.com/ivanswip/32/3182_2.png) [@ivanswip](https://community.passbolt.com/u/ivanswip)
#### Post date: [September 21, 2023, 6:20am UTC](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493/38 "2023-09-21T06:20:18Z")

</div>

I had the same error on my Synology, the page would not display.  
Solution:  
On the Login portal tab, enter the domain [yousite.synology.me](http://yousite.synology.me)

[Previous page](https://community.passbolt.com/t/blank-page-new-install-on-synology-nas-docker/6493.md?page=1)
