Blank Page - New Install on Synology Nas Docker

Thanks for taking the time @mariushosting

1 Like

Thanks Marius also for your great tutorial :+1:

1 Like

I have active web socket at STEP 7.


To make sure I delete and create web socket again.
Checking other steps again too


I found db folder permission is Read only (jwt and gpg folders permission are everyone read and write)
I type SMTP info as not gmail. (typed other SMTP info)

Still getting blank page with Passbolt text on header

@mariushosting Thank you for your awesome guide and support! I have installed other app on my nas thanks to your guide. I just sent 33 Euro donation to you :slightly_smiling_face:

Looks like cache. Please follow this guide: Synology: How to Clean Docker – Marius Hosting and delete passbolt

After that reinstall it from scratch. This will solve the issue for sure.


1 Like

I have installed Passbolt on Synology using @mariushosting 's guide
Unable to setup account

Access to this service requires an invitation. This email is not associated with any approved users on this domain. Please contact your administrator to request an invitation link.
Try another email

Please advise
Thank you

Reinstall from scratch or update your stack
You forget to add email in the compose.

1 Like

Thanks Marius

Part of my compose , anywhere I have missed?, plz advise. Thank you

DEBUG: false


Reinstalled from scratch, same error

any suggestions plz

Thank you

Health Check

[FAIL] The server OpenPGP key is not set
[FAIL] The server key fingerprint doesn't match the one defined in /etc/passbolt/passbolt.php.
[FAIL] The server public key defined in the /etc/passbolt/passbolt.php (or environment variables) is not in 
[FAIL] The server key does not have a valid email id.the keyring

Hi these are the errors on health Check, please suggest to remedy them

Thank you


____                  __          ____  
    / __ \____  _____ ____/ /_  ____  / / /_ 
   / /_/ / __ `/ ___/ ___/ __ \/ __ \/ / __/ 
  / ____/ /_/ (__  |__  ) /_/ / /_/ / / /    
 /_/    \__,_/____/____/_.___/\____/_/\__/   

 Open source password manager for teams
 Healthcheck shell         


 [PASS] PHP version 7.4.33.
 [PASS] PCRE compiled with unicode support.
 [PASS] The temporary directory and its content are writable and not executable.
 [PASS] The logs directory and its content are writable.
 [PASS] GD or Imagick extension is installed.
 [PASS] Intl extension is installed.
 [PASS] Mbstring extension is installed.

 Config files

 [PASS] The application config file is present
 [WARN] The passbolt config file is missing in /etc/passbolt/
 [HELP] Copy /etc/passbolt/passbolt.default.php to /etc/passbolt/passbolt.php
 [HELP] The passbolt config file is not required if passbolt is configured with environment variables

 Core config

 [PASS] Debug mode is off.
 [PASS] Cache is working.
 [PASS] Unique value set for security.salt
 [PASS] Full base url is set to
 [PASS] App.fullBaseUrl validation OK.
 [PASS] /healthcheck/status is reachable.

 SSL Certificate

 [PASS] SSL peer certificate validates
 [PASS] Hostname is matching in SSL certificate.
 [PASS] Not using a self-signed certificate


 [PASS] The application is able to connect to the database
 [PASS] 26 tables found
 [PASS] Some default content is present
 [PASS] The database schema up to date.

 GPG Configuration

 [PASS] PHP GPG Module is installed and loaded.
 [PASS] The environment variable GNUPGHOME is set to /var/lib/passbolt/.gnupg.
 [PASS] The directory /var/lib/passbolt/.gnupg containing the keyring is writable by the webserver user.
 [FAIL] The server OpenPGP key is not set
 [HELP] Create a key, export it and add the fingerprint to /etc/passbolt/passbolt.php
 [HELP] See.
 [PASS] The public key file is defined in /etc/passbolt/passbolt.php and readable.
 [PASS] The private key file is defined in /etc/passbolt/passbolt.php and readable.
 [FAIL] The server key fingerprint doesn't match the one defined in /etc/passbolt/passbolt.php.
 [HELP] Double check the key fingerprint, example: 
 [HELP] sudo su -s /bin/bash -c "gpg --list-keys --fingerprint --home /var/lib/passbolt/.gnupg" www-data | grep -i -B 2 'SERVER_KEY_EMAIL'
 [HELP] SERVER_KEY_EMAIL: The email you used when you generated the server key.
 [HELP] See.
 [FAIL] The server public key defined in the /etc/passbolt/passbolt.php (or environment variables) is not in the keyring
 [HELP] Import the private server key in the keyring of the webserver user.
 [HELP] you can try:
 [HELP] sudo su -s /bin/bash -c "gpg --home /var/lib/passbolt/.gnupg --import /etc/passbolt/gpg/serverkey_private.asc" www-data
 [FAIL] The server key does not have a valid email id.
 [HELP] Edit or generate another key with a valid email id.

 Application configuration

 [PASS] Using latest passbolt version (3.11.0).
 [PASS] Passbolt is configured to force SSL use.
 [PASS] App.fullBaseUrl is set to HTTPS.
 [PASS] Selenium API endpoints are disabled.
 [PASS] Search engine robots are told not to index content.
 [PASS] The Self Registration plugin is enabled.
 [PASS] Registration is closed, only administrators can add users.
 [PASS] The deprecated self registration public setting was not found in /etc/passbolt/passbolt.php.
 [WARN] Host availability checking is disabled.
 [HELP] Make sure this instance is not publicly available on the internet.
 [HELP] Or set the PASSBOLT_EMAIL_VALIDATE_MX environment variable to true.
 [HELP] Or set to true in /etc/passbolt/passbolt.php.
 [PASS] Serving the compiled version of the javascript app.
 [WARN] Some email notifications are disabled by the administrator.

 JWT Authentication

 [PASS] The JWT Authentication plugin is enabled
 [PASS] The /etc/passbolt/jwt/ directory is not writable.
 [PASS] A valid JWT key pair was found

 SMTP Settings

 [PASS] The SMTP Settings plugin is enabled.
 [PASS] SMTP Settings coherent. You may send a test email to validate them.
 [WARN] The SMTP Settings source is: env variables.
 [HELP] It is recommended to set the SMTP Settings in the database through the administration section.
 [WARN] The SMTP Settings plugin endpoints are enabled.
 [HELP] It is recommended to disable the plugin endpoints.
 [HELP] Or set to true in /etc/passbolt/passbolt.php.

 [FAIL] 4 error(s) found. Hang in there!

Hi @luckyearl The suggested remedies are listed on the [HELP] lines in the healthcheck. Try those first, and post back if you have trouble.

Thanks @garrett
Just managed to crack it
For Someone who is looking for solution
Portainer → Container → Console

.bin/cake passbolt register_user -u email -f name -l surname -r admin

This shud set the user

1 Like

And for completion, this shud sort the gpg errors

  --home $GNUPGHOME\
  --list-keys \
  ${} | \
  grep -Ev "^(pub|sub|uid|^$)" | tr -d ' ')"
1 Like

I can-t replicate your issue in any of my 5 NAS devices, looks like The /etc/passbolt/jwt/ directory is not writable on your NAS this means you forget to add write permission to the folder. Btw, looks like I have an old version installed I will update it tonight.

I follow Synology: How to Clean Docker – Marius Hosting
I remove images and other on portainer related passbolt and directories on file stations too.
Then install from scratch. When I Click Deploy the stack on portainer, I get this error

Deployment error
mkdir /data/compose no such file or directory

Thanks Marius!

Hi Yohan
did you create the db, gpg & jwt folders in passbolt folder?

Thank you for updating your website with ninstructions to create first account
Can I plz suggest to add instructions for

  1. fixing PGP key errors
  2. Connecting to mobile app

Thank you


I had the same error on my Synology, the page would not display.
On the Login portal tab, enter the domain