Cannot login via API - There is no user associated with this key

We have a self-hosted passbolt installation. I have a user account, and it gave me a private key during installation, I can use the UI.

I have read through https://help.passbolt.com/api/authentication and I am trying to authenticate via API.

I have extracted the fingerprint from the key, and it matches the fingerprint of the public key I can retrieve via the GUI, and I have tried to post it to the server:

curl -k -X POST --data-binary @./passbolt.login.step1.txt 'https://passbolt.me.local/auth/login.json'

where passbolt.login.step1.txt looks like

'data' => [
    'gpg_auth' => [
        'keyid' => '0431 2461 86EA AD86 BAD1 D74B 53D7 3629 A6FA 9FD3'
    ]
]

I have also tried with the spaces removed

        ...
        'keyid' => '0431246186EAAD86BAD1D74B53D73629A6FA9FD3'
        ...

both attempts report:

"message": "The authentication failed. There is no user associated with this key. No key id set.",

There is nothing in the error.log.

I’m sure I’m doing something wrong, but the authentication page isn’t very clear on what format the fingerprint should be. I have tried removing the single quotes, I have tried wrapping it in <>, I tried turning it into json and posting that.

Hoping someone can indicate what I’m doing wrong, or somewhere else I can look for information.

Thanks.

curl -v -H "Content-Type: application/json" -v -k -X POST -d '{"gpg_auth": {"keyid": "0431246186EAAD86BAD1D74B53D73629A6FA9FD3"}}' 'http://passbolt.me.local/auth/login.json'

The documentation should probably be updated.