Docker hub latest-debian out of date

The main difference between these two images is the debian version used.

On 4.0.2-2 debian released a new stable (12.0)

❯ docker run -ti passbolt/passbolt:4.0.2-2-ce-non-root bash
www-data@fd06965bd3f0:/usr/share/php/passbolt$ cat /etc/debian_version
12.0

On 4.0.2-1 debian stable was 11.7

❯ docker run -ti passbolt/passbolt:4.0.2-1-ce-non-root bash
www-data@a8968b21ced6:/usr/share/php/passbolt$ cat /etc/debian_version
11.7

okay interesting, so with the os change it seems the package that generates the gpg keys also changed and made it incompatible with my cpu?

so… update:
debian base image 11.8 gets:
gpg (2.2.27-2+deb11u2)
and
debian base image 12 gets:
gpg (2.2.40-1.1)

so must be an issue with the gpg package in the newer versions (with my cpu)?

That would be surprising but I have no other recommendations than try to run gpg on a vanilla debian 12 container on your NAS to confirm.

Yes I did exactly that.

I ran the gpg command from the passbolt scripts in a debian 12 container → does not work. same in an 11.8 container → works.

I did not know what else to do so I modified your Dockerfile to use a debian 11 base image and I added the sury.org repositories so the current php version is available in the container…

I mean I understand if you would not want to do that but maybe providing a passbolt deb 11 image for people like me with “incompatible” cpus is something you could consider?

1 Like

Hey @tofuSCHNITZEL glad to hear you found a workaround!
You could add a feature request in the forum to see if there is interest in debian11 images, based on that we can decide if we add them.

Debian11 LTS support ends in 2026 though, you will need a plan for that too :sweat_smile:

Hey !
Thank’s a lot for this thread. It’s been a while I’m trying to make passbolt work on my Synology NAS through Docker. I was having the same issue and the same solution worked for me too.

I’m using a DS216+II under DSM 7.1.1 and the processor is an INTEL Celeron N3060.
If this helps…