Duo MFA not working RockyLinux 9.1 [egress setsebool]

[x ] I have read intro post: About the Installation Issues category
[ x] I have read the tutorials, help and searched for similar issues
[x ] I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck
[x ] I describe the steps I have taken to trouble shoot the problem
[x ] I describe the steps on how to reproduce the issue

Environment: Rockylinux 9.1 minimal install running on HyperV

I have my Passbolt working perfectly except I can’t get Duo MFA working. I’m following these instructions.

We have a paid subscription with Duo and have existing SDK apps setup in there already. I’ve created the Web SDK and transferred the information over to the Passbolt portal, but when I hit Save settings I get the error:

Error: Could not authenticate multi-factor authentication provider configuration.

I even tried using an existing Web SDK without luck.
Any ideas?

Hi @cwhitmore

I don’t think I’ve seen this one before. Are there quotes or possibly an inadvertant space added on Duo’s end for credentials? Seems like it would indicate bad credentials that are losing or adding something in transfer when copied? Is that how you would see it too?

Anything on the network blocking the outgoing call?

You were correct @garrett. Duo setup requires egress https to be enabled.
For anyone else with this issue this the command that fixed it.

sudo setsebool -P httpd_can_network_connect 1

1 Like