Error registration User

#1

hello , I install from source the passbolt fine but when i trying to register the first user the extension os passbolt do a error.
“response”: {
“header”: {
“id”: “dc66ffa2-4095-4e5c-8b43-253925fe7383”,
“status”: “error”,
“servertime”: 1557919120,
“title”: “app___error”,
“action”: “d318229b-7ff3-5b5b-a186-1d908d535522”,
“message”: “A route matching “/users/validateAccount/03649c2a-73c3-46d4-8bb4-281d2780d93c.json” could not be found.”,
“url”: “/”,
“code”: 404
},
“body”: “”

And the error in error.log is:
2019-05-15 11:18:40 Error: [Cake\Routing\Exception\MissingRouteException] A route matching “/users/validateAccount/03649c2a-73c3-46d4-8bb4-281d2780d93c.json” could not be found.
Exception Attributes: array (
‘url’ => ‘/users/validateAccount/03649c2a-73c3-46d4-8bb4-281d2780d93c.json’,
)
Request URL: /users/validateAccount/03649c2a-73c3-46d4-8bb4-281d2780d93c.json

#2

Hey @tecnico,

Sorry to learn you’re having trouble registering your user. Just a heads up, that URL in question is only meant for form submission and won’t work from the browser’s address bar.

To better understand your issue can you please give a detailed step by step description of how did you try to register and at what step the error appears?

#3

Sorry for my bad english , yes the error is in the extension bar , put a image of this

#4

Thank you for including the screenshot @tecnico. We’re looking into this and will update you with a fix soon.

#5

@tecnico

What happen if you go to https://PASSBOLT_DOMAIN, do you also have an error ?

Can you please provide us with the output of the healthcheck command ?

From your passbolt directory (should be /var/www/passbolt), execute the following command as www-data (or nginx depending on which user runs your webserver).

su -s /bin/bash -c “./bin/cake passbolt healthcheck” www-data

Are you using apache or nginx ?

#6

Dear , I´m using Apache with PHP-FPM in a server with DirectAdmin I used direct user of exec the domain.
This is a screenshot of passbolt healthcheck

#7

This is a screenshot of https://domain

#8

Did you have to accept the SSL certificate when you went to https://PASSBOLT_DOMAIN ?
Did you accept the certificate after the plugin registration attempt ?

#9

Dear , Yes i changed the certificate with one valid and this retry the problem and it still does not work

#10

Hey @tecnico Can you check your apache config and make sure the root is pointing to <your_passbolt_folder>/webroot and not just <your_passbolt_folder>?

#11

If a pointing root to webroot the web do a error 500 , I view the index.php of passbolt_folder and this require a webroot/index.php
therefore it is not the error

#12

Hi @tecnico,

Sorry to hear you are having problems setting passbolt, following a few questions that might help us to understand the problem:

  • Could you also share the configuration of your webserver that is meant to run passbolt?
  • Anything on the apache logs or passbolt error.log would be also useful
#13

Yes , This is the configuration.

SecRuleEngine off
ServerName www.passbolt.bigfootcomputers.es
ServerAlias www.passbolt.bigfootcomputers.es passbolt.bigfootcomputers.es
ServerAdmin webmaster@bigfootcomputers.es
DocumentRoot /home/bigfoot/domains/bigfootcomputers.es/public_html/passbolt
ScriptAlias /cgi-bin/ /home/bigfoot/domains/bigfootcomputers.es/public_html/passbolt/cgi-bin/
UseCanonicalName OFF
<IfModule !mod_ruid2.c>
SuexecUserGroup bigfoot bigfoot

CustomLog /var/log/httpd/domains/bigfootcomputers.es.passbolt.bytes bytes
CustomLog /var/log/httpd/domains/bigfootcomputers.es.passbolt.log combined
ErrorLog /var/log/httpd/domains/bigfootcomputers.es.passbolt.error.log
<FilesMatch “.(inc|php|phtml|phps|php72)$”>
AddHandler “proxy:unix:/usr/local/php72/sockets/bigfoot.sock|fcgi://localhost” .inc .php .phtml .php72

<Directory /home/bigfoot/domains/bigfootcomputers.es/public_html>

#15

This is error log of passbolt
2019-05-17 09:04:11 Error: [Cake\Routing\Exception\MissingRouteException] A route matching “/users/validateAccount/03649c2a-73c3-46d4-8bb4-281d2780d93c.json” could not be found.
Exception Attributes: array (
‘url’ => ‘/users/validateAccount/03649c2a-73c3-46d4-8bb4-281d2780d93c.json’,
)
Request URL: /users/validateAccount/03649c2a-73c3-46d4-8bb4-281d2780d93c.json

2019-05-17 09:05:12 Error: [Cake\Routing\Exception\MissingRouteException] A route matching “/users/validateAccount/03649c2a-73c3-46d4-8bb4-281d2780d93c.json” could not be found.
Exception Attributes: array (
‘url’ => ‘/users/validateAccount/03649c2a-73c3-46d4-8bb4-281d2780d93c.json’,
)
Request URL: /users/validateAccount/03649c2a-73c3-46d4-8bb4-281d2780d93c.json

#16

Hi again @tecnico,

It is hard for me to give you specific instructions as I’m not familiar with your environment and it is not part (yet) of our official installation methods. However, what I can give you is a tested and known working apache config for making passbolt run with apache2 and php7.0-fpm (debian 9 defaults).

After installing all the required php extensions, git clone from https://github.com/passbolt/passbolt_apirepo and doing the composer install --no-dev I set up apache following the cakephp recommendations: https://book.cakephp.org/3.0/en/installation.html and this is what I have:

<VirtualHost *:80>
	ServerAdmin webmaster@localhost
	DocumentRoot /var/www/html/passbolt_api/webroot

	<Directory /var/www/html/passbolt_api>
		AllowOverride All
	</Directory>	
  	<FilesMatch "\.php$">
            SetHandler "proxy:fcgi://127.0.0.1:9000/"
        </FilesMatch>
	
	ErrorLog ${APACHE_LOG_DIR}/error.log
	CustomLog ${APACHE_LOG_DIR}/access.log combined

</VirtualHost>

Note the snip above is the minimal setup you need to get pasbolt running with apache and php-fpm. You will need to enable the following apache modules:

  • a2enmod rewrite
  • a2enmod php7.0-fpm (or the version you use of php-fpm)

You will also be encouraged to set apache up with SSL, this part I leave to you as you have it already running and most likely that won’t be a problem.

Heads up that documentroot has ALWAYS to point to webroot. Making it point to the upper directory (in my case passbolt_api) could have security implications depending on your setup.

Hope this helps you!

#17

yes I enabled all but i think that the problem is another , I trying this


but do a error

#18

But If I try to the access via web

#19

I corrected the problem I found that the problem is in the directory directive I add this:
Options FollowSymLinks
AllowOverride All
Order Allow,Deny
Allow from all
And the passbolt works correctly

2 Likes