Having a heck of a time moving to 20.04 and v3

I am running 2.13.5 on a fully up to date 18.04 ubuntu install.

I installed v2 from source and have been updating via git.

I’ve tried running the Ubuntu upgrade from 18.04 to 20.04 and then running the package migration and end up with either a 502 nginx error, the default nginx welcome screen or a fully unresponsive web host.

I also tried spinning up an entirely new 20.04 host and installed v3. I migrated my my config file, GPG server key and imported an export of my database then ran the database migration with similar results.

Got this working.
This is what I did.

Upgrade to 20.04
Git pull and update database schema
install package per the migrate instructions.

This is where I ran into an issue, despite selecting auto for SSL and having Certbot nginx installed the nginx-passbolt-ssl config was not created in sites-available/sites-enabled.

I pulled the old ssl config and replaced the bottom portion with the info from the current http version and was finally able to access the web UI.