Passbolt.php changes not taking effect

[ * ] I have read intro post: About the Installation Issues category
[* ] I have read the tutorials, help and searched for similar issues
[* ] I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck
[* ] I describe the steps I have taken to trouble shoot the problem
I describe the steps on how to reproduce the issue

I have a very strange issue going on. Whenever I make a change to the passbolt.php file the changes are not reflected when I rerun any tests. For example I am having email issues so have tried to change TLS from true to null. Change is made on file ok but when i run the bash command for the email debug is still says TRUE.

Is there something need to rerun to update the changes?

Hey, the issue here is that we have moved the email server settings to the database instead of the passbolt.php file. So, the changes you make there are not being picked up at all. To make any changes to the email server settings you’ll need to log in and go to the admin section and make the changes there.

1 Like

Hi Clayton.

Thank for the response. The problem I have is the administrators account is the one that we can’t log into to make changes.

Could we install say PHPAdmin and login and make the changes directly on the database that way? Is that possible or is there any other way you could suggest that may be applicable.

Thank you. Peter

You could go with PHPAdmin and directly edit the db but that would be a bit messy as you’d have to decrypt the settings and encrypt them again. The easier route is to:

  • Request the recovery email to be sent even though it won’t go anywhere
  • Log into the server, and then the database, and be sure to use the passbolt database if you don’t default into that one
  • Run this query:
    • select email, subject, template_vars from email_queue order by created desc limit 3;
      • I chose 3 here in case someone else tries to recover their account too

Your output should look something like the below, I’ve bolded two important fields which you’ll need:

| clayton@passbolt.local | Your account recovery, C! | {“body”:{“user”:{“id”:“73a51858-0435-47d5-bc7f-62eb7ff10590”,“role_id”:“15537ea1-46cd-4e12-b2f9-a50c818b60a2”,“username”:“clayton@passbolt.local”,“active”:true,“deleted”:false,“created”:“2022-11-21T11:15:48+00:00”,“modified”:“2023-02-15T15:50:34+00:00”,“profile”:{“id”:“865a9a8d-60e8-4a11-bf05-f26ea6aa2a2b”,“user_id”:“73a51858-0435-47d5-bc7f-62eb7ff10590”,“first_name”:“C”,“last_name”:“S”,“created”:“2022-11-21T11:15:48+00:00”,“modified”:“2023-02-15T15:50:34+00:00”,“avatar”:{“id”:“2b814079-edc8-4739-9b97-235ea03b05bc”,“profile_id”:“865a9a8d-60e8-4a11-bf05-f26ea6aa2a2b”,“created”:“2023-01-02T11:56:55+00:00”,“modified”:“2023-02-15T15:50:34+00:00”,“url”:{“medium”:“https://passbolt.local/avatars/view/2b814079-edc8-4739-9b97-235ea03b05bc/medium.jpg”,“small”:“https://passbolt.local/avatars/view/2b814079-edc8-4739-9b97-235ea03b05bc/small.jpg”}}},“role”:{“id”:“15537ea1-46cd-4e12-b2f9-a50c818b60a2”,“name”:“admin”,“description”:“Organization administrator”,“created”:“2012-07-04T13:39:25+00:00”,“modified”:“2012-07-04T13:39:25+00:00”},“last_logged_in”:null},“token”:{" user_id":“73a51858-0435-47d5-bc7f-62eb7ff10590”," token":“98cec5d3-5b87-4ec7-8aad-cafe0cf9b6e3”,“active”:true,“type”:“recover”,“data”:null,“created”:“2023-02-17T13:37:07+00:00”,“modified”:“2023-02-17T13:37:07+00:00”,“id”:“b0dffa11-8e9c-4434-878d-4ed22d9a107b”},“case”:“default”,“fullBaseUrl”:“https://passbolt.local”},“title”:“Your account recovery, C!”,“locale”:“en-UK”} |

Then you’ll be able to change the settings for the email server

1 Like


Brilliant. Thank you so much. All fixed.

Regards, Peter