Problem accessing database

I have one, but in that one the mysql cli didn’t start, it’s from a previous machine, but if I can save that one it would also work for me.

ok, it is probably best to try working with that one.

Is the mysql cli issue the one in your other post?

1 Like

Yes, it’s that one, I ended up abandoning it because I thought it was a lost cause, I managed to clear more space for it but it still wouldn’t start.

After you cleared up space what was the error you received when trying to start it?

1 Like

This was the error, that the mysql community server was not starting up

In this computer it was passbolt installed well with the data, they are a little old, but as I say I am worth, if I could enter or retrieve this data would also be worth me.

Could you run just a sudo systemctl start mysql?

Additionally did you find anything in these two files?

  • /var/log/syslog
  • /var/log/mysql/error.log
1 Like

Yes, i have this 2 files

Great! It looks like the error is due to permissions. Can you check those with ls -al /var/lib/mysql?

1 Like

I assume you can’t run the OS but you have access to the storage drive.
Have you tried to run a live Ubuntu (or other Linux distribution) and try to mount your storage drive to try to back up your MySQL using the live distribution but your old machine storage mount?

1 Like

Yes, I tried with debian, it gave me the same problem as this computer, that I could not access the database, that the user did not have permissions and so on.
The one I’m with now is like a copy of the one that died, but with a problem in the mysql cli.

I managed to solve it with the Debian live cd at the end as you said, it was more difficult than it seemed but it is already working with all the passwords again, thank you very much to all for the help @antony @Termindiego25 @Steph @clayton , if someday you come to Alicante in Spain, let me know that I invite you to eat :grin:.

4 Likes