Verification emails are never sent to SMTP server

[v] I have read intro post: About the Installation Issues category
[v] I have read the tutorials, help and searched for similar issues
[v] I provide relevant information about my server (component names and versions, etc.)
[N/A] I provide a copy of my logs and healthcheck (cannot run h-check, logs have nothing relevant).
[x] I describe the steps I have taken to trouble shoot the problem
[x] I describe the steps on how to reproduce the issue

Running Passbolt CE on Ubuntu Server LTS 20.04 with the latest updates.

I’m in the process of testing Passbolt CE for my team, and everything was going swimmingly. First install was smooth, got all emails etc. We are only testing it on the local LAN we are using IPs rather than DNS, but this was no issue.

A second install (on the same server, rolled back to before passbolt was installed), intended for a larger group to test. Opened a port in the router to allow for a separate subnet to access passbolt and now it simply does not send verification emails.

Installation steps

Following the official documentation on how to install on Ubuntu 20.04. Using the script and apt packages. Like before the install works like a charm.

  1. Created self-signed cert, installed, and works.
  2. After the cli portion of the install, went to the ip of the router that port forwards to the Passbolt server ( and did the rest of the setup (server key etc). Set the “URL” of the server to the router and port combo so the links recieved in emails should point to it/work.
  3. After setup, no errors and all lights green, I point my browser at the server and get the “please enter your email to continue” dialog.
  4. Enter the email I used for the administrator user created during initial setup.
  5. Get the “we’ve sent you an email” page.
  6. No verification email ever arrives.

Trouble shooting steps

  • Sent test mail during install, which arrived without issue.
  • Sent manual test mail using cake, which arrives (using same address as the admin user is registered with).
  • Checked mail queue, which is empty.
  • Checked that cron is running and the job exists.
  • Checked the error /log which has nothing in it.
  • Checked the email_queue table, empty.
  • Checked the action_logs table, which shows the POST/GET requests with no issues.
  • Checked that the user exists in the profiles and users tables, and the email is correct.
  • Checked Mailserver logs (Postfix) and can see the test emails going smoothly, but no email recieved from the Passbolt server for the verification.

So at this point I am stumped. Would double check that the “Administration > Email Notification Settings” are set to send verification emails, but a little hard when I cannot log in. Also tried re-installing just to make sure there wasn’t something I missed during install.

Anyone got any ideas about this one?
I know it would be a lot easier if we just setup a DNS record etc, but can’t get to that step before finishing this round of testing.

@Kjell if emails are not in the queue and you receive the test email that could be indeed because the email notification settings are set to be switched off. If you have access to the database, you can drop a potential config like this:

delete from organization_settings where property = 'emailNotification';

That fixed it, thank you very much for the help.