Can I use the community edition on AWS EC2

I installed Community PassBolt locally and it worked perfectly so I decided to put the same version on EC2 but I am facing issues.

  1. The SSL version is not opening hence I cannot configure the server to work with DB
  2. The non-secured version was configured successfully but trying to open it again using the secured link, this was not working.

Can this community edition be installed on AWS EC2 because I saw somewhere where VM is cancelled.

:wave: @limanalhassann

Welcome to the Passbolt Community Forum!

I am hoping the link below might help you. I have not used aws. Sorry, if it does not help. It looks like Passbolt CE works with EC2 but you might need to use RDS also.

My case is a bit different from this, I have all working perfectly but only on the IP address of the machine which is not encrypted, I cannot access the machine from SSL domain created. This is the scenario:

Installing on EC2, I have a public address which I was able to use to access the configuration 34.53.422.3/install (something like this), I also have something like this but this is not opening well, like it looses its graphics and when I tried to configure, it tells me I am trying to configure over as unsecure server and it kept returning me back to database configuration with a horrible UI which has no single image (like when you deploy your web server without an image folder). http://34.53.422.3/install works perfect for installation but I am not able to access the app with after installation from the IP, it brings a blank page. I am limited to only putting 2 links in my reply.

I hope you understand my explanation.


Sorry, I do not know the answer. Someone from the Passbolt team or another community member should have an answer for you soon. Sorry for the delay!

Thanks for the time, I appreciate

Maybe can you have a look at this link: Passbolt Help | Auto configure HTTPS with Let's Encrypt on AWS

1 Like