Can't go past step "enter your passphrase" on mobile when binding the account

I have read intro post: <link removed for reasons of 2 links per new user>
I have read the tutorials, help and searched for similar issues
Couldn’t find anything.
I provide relevant information about my server (component names and versions, etc.)
Passbolt - passbolt:latest-ce-non-root (docker image)
mariadb 10.11
docker v2.14.1-qnap1

Running on a QNAP box (TS-453D) with QTS version

I provide a copy of my logs and healthcheck
Client: client.txt - Google Drive
Server: server.txt - Google Drive
I describe the steps I have taken to trouble shoot the problem
reprovision passbolt docker image
reinstall the app from the google play
try reprovisioning the account
I describe the steps on how to reproduce the issue
I scan the QR. It goes great, then it gives me the passphrase prompt on the phone, and boom. Error. “Login data is incorrect”, but when i put wrong passphrase it greets me with “Incorrect passphrase or decryption error”

Hello @Lordomus and Welcome to the forum!

According to the provided logs, you have probably MFA activated on your account and is seems that it is failing this step.

What MFA do you use exactly?

I don’t know yes what could be your problem exactly, but I know that these kind of issues could happen if the times are not synchronised (even if it’s subtle).
Do you know if both your server and your mobile are time synced?

[EDIT]: also I’m thinking that in your logs, it happens when the JWT endpoints are used. Maybe your server doesn’t have the JWT elements working.
You can check that by connecting to your server using a terminal and running a health-check command. You can follow the procedure there Passbolt Help | How to generate JWT key pair manually

Thats the thing. There is no MFA enabled.
All MFA’s are disabled in settings, there is no MFA applied to the account.
It is a fresh install of Passbolt.
All devices in my premises are synced to Cloudflare NTP.

[EDIT]: nevermind got that (healthcheck) working.

JWT is shown as all good in health-check

JWT Authentication

[PASS] The JWT Authentication plugin is enabled
[PASS] The /etc/passbolt/jwt/ directory is not writable.
[PASS] A valid JWT key pair was found