Can't open the default site


#1

Hi,

I installed passbolt on Ubuntu 18.04 LTS in a fresh installed virtual machine. The setup went fine, but I can’t access the default passbolt page. I only get the default “welcome to nginx” page.

I only get this page when I open the IP of the virtual machine in the browser. The hostname I set during the setup cannot be resolved by the browser (ERR_NAME_NOT_RESOLVED).

We don’t use SSL for now because it’s just a test installation which can only be called in our internal network.

Can someone please help me or point me in the right direction where I can find a solution for this?

Thanks
Tim


#2

Hi, it looks like that nginx your request is being routed through the nginx default server config.

If your client machine is linux you could setup a /etc/hosts entry pointing to the hostname you set during your setup so your browser will be able to access it.

As an example of your /etc/hosts on your client machine:

passbolt.local 127.0.0.1

That would make passbolt.local accessible for your browser localted on ip 127.0.0.1. Please adjust to your hostname and ip address pair.

Another solution would be to delete the nginx default server config and modify the passbolt one to catch any request.

rm /etc/nginx/sites-enabled/default
vim /etc/nginx/conf.d/passbolt.conf

Change line:

server_name passbolt.local;

For:

server_name _;

That way pointing to the server ip should route your request to the passbolt application.

Hope this helps.


closed #3

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.