Debian 11 - failed to fetch InRelease, 403 forbidden

Hi,
I’m attempting to install PassboltPro in a server in AWS, and cannot seem to get a connection to the apt repo:

E: Failed to fetch https://download.passbolt.com/pro/debian/dists/buster/InRelease 403 Forbidden [IP: 104.22.70.135 443]

It wouldn’t let me get the apt key, either, though I worked around that by downloading it elsewhere and installing it on the server manually. There are no egress rules blocking this, the 403 response seems to be coming from the Apt repo.

Are you blocking AWS IP ranges? How am I meant to install PassboltPro without the Debian repository? is Docker my only option here?

Cheers,
Liz Rea
ByWater Solutions

Hi @wizzyrea I’m sorry to hear you had to deal with this. There have been intermittent repo access issues for a small number of users recently. Thank you for mentioning this happened. When you try it again, please post back if it’s still an issue.

The package install is the recommend way, but Docker is also an option. I don’t think you’ve done anything out of place - I think it’s the repo, though I don’t oversee that to definitively confirm it.

PS: the core team gets smaller over the weekend, but the forum is active.

I have performed an installation on a debian 11 without any issues (following Passbolt Help | Install Passbolt Pro on Debian 11 (Bullseye)).
I need to have a look for the AWS AMI.
What is bothering me here is the URL of the repo that you shared.
It is pointing to buster (debian 10) instead of bullseye (debian 11).

I will make a try later today.

Best,
Max

Thank you both for your replies - I had tried it with both Buster and bullseye (thinking maybe as with some other projects the sources were interchangeable). Thanks for confirming that there is a requirement there for the correct distro.

Lots of places block AWS IP ranges for many legitimate reasons, I was wondering if that was what was happening here. Happy to change tack and try from a different cloud if that would help.

Likely will try to give this another go today, fingers crossed!

Liz

Just FYI,

There is no bullseye repo, buster and bullseye share the buster repo.

1 Like

Lovely, I’ll use only Buster from now on. :slightly_smiling_face:

Hi,

The forbidden messages are the same today, as follows:

Err:7 download.passbolt. com/pro/debian buster/stable amd64 Packages
403 Forbidden [IP: 172.67.7.1 443]
Ign:8 https: //download .passbolt .com/pro/debian buster/stable all Packages
Ign:9 https: //download .passbolt .com/pro/debian buster/stable Translation-en
Reading package lists… Done
W: The repository ‘https:// download .passbolt .com/pro/debian buster Release’ does not have a Release file.
N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch https://download.passbolt.com/pro/debian/dists/buster/stable/binary-amd64/Packages 403 Forbidden [IP: 172.67.7.1 443]
E: Some index files failed to download. They have been ignored, or old ones used instead.

This is using AWS’s Debian 11 ami from an AWS IP range.

Next week I may give this a try from Google cloud. If you think of something else to try, do let me know!

Cheers,
Liz

Just noting that I had to mess up the urls in the error output as it wouldn’t let me post more than 2 links. :slight_smile:

1 Like

Hey @wizzyrea,

Hope you’re doing well, I just popped an EC2 instance on AWS with the most basic configuration and I had no issues to install Passbolt on it. Are you able to install other package? What kind of network configuration do you have on your EC2?

Cheers,
Gérold.

1 Like

I just checked that ip and it’s cloudflare. Must be a configuration issue there.

1 Like

Hi friends,

Modicum of success here - first off, I stopped my aws instance that was not the ami, and restarted it to get a new IP, and the apt update worked flawlessly first time. Since I had already done a bunch of config that was now going to have to be redone anyway, I changed tack and tried the Amazon AMI with our passbolt pro key, and that worked very well and is probably the direction I’ll end up going.

Thanks for your attention here - you did help me narrow down that it was likely my AWS IP and Cloudflare that was causing the problem.

Long live passbolt,
Liz Rea
ByWater Solutions

3 Likes