Disable second login to fill passwords in browser?

I login to Passbolt with a ID/Password and enter the OTP. I select a resource, open URI in a browser tab. When the login page comes up, I click the Passbolt key icon in the ID field and choose either the password or browse. Then I get hit with another Passbolt passphrase request and how long to remember it for (5min-Until I logout). Is it possible to disable this second login?

Hello, it asks again for security reasons. If you don’t check the remember option, it will ask every time (as logic, you chose don’t remember).
If you check until logout, it will keep your session unlocked until you close the browser or logout from the Passbolt website

Even though I don’t check the remember option when I first login, I’m still already logged in, with MFA, my tokenID/color have already been validated, and I haven’t closed my browser. I get that it can be for added security, but I don’t see the added benefit. I thought I’m not checking "remember " because I don’t want it to remember for the next time I launch the browser.

I just seems overkill to me.