Domain name format is incorrect

Checklist
I have read intro post:
I have read the tutorials, help and searched for similar issues
I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck
I describe the steps I have taken to trouble shoot the problem
I describe the steps on how to reproduce the issue

I am updating from an old v2 version of Passbolt on an ubuntu server instillation following the following (Passbolt Help | Migrate passbolt CE from install scripts to Ubuntu package) and I am stuck on the following step:

sudo dpkg-reconfigure passbolt-ce-server

The issue is that it does not accept my domain name which and gives the following error:

image

My domain name is is a Punycode name so possibly that is why. Can anybody verify whether or not punycode domains are supported and if not how can work around this tomanually reconfigure my nginx config?

My domain name is of the form auto.exampleDümain.com, and I have tried the raw punycode version as well.

Can provide more info if required.

I suppose it depends on what you are running the command to do. If you are doing this to set up Let’s Encrypt certs, for example, then someone else needs to verify the process (because I’m not as familiar with the package internals).

As you are not showing https in your example domain and if you are just changing the name, then I think to get around it you could provide any domain that passes, and then go back and change the domain in the separate passbolt and nginx configuration files.

This is not guaranteed to work, but another step to try.

ref: NGINX may handle it fine: punycode - Unicode domain name in Nginx server_name - Stack Overflow

I’ll try using another domain and then switching things over. I am using the auto mode of the reconfigure nginx step and I am not passing “https” into the domain field as that does not seem to be the form that is required (though I have tried it to the same effect).

I know NGINX handles punycodes as I was using this domain with the previous version of passbolt.

Was able to manually update the old configs for my NGINX available sites for this particular domain.

Would be nice if the domain validation code could be updated to support punycode domains as that’s what really pushed me off the well trodden path.

By setting my machines ip as the domain name it seems a nginx-passbolt.conf file was generated which I was able to use as insipration. Turns out I needed to update the fastcgi_pass to the new php7.4-fpm unix socket url. It’s worth noting that the new config generated by passbolt had unix:/run/php/__PHP_SOCK__; which was also wrong but gave me enough of a hint.

1 Like

I believe this is the section of the package install code passbolt_packaging/debian/config at 1d7cf040c62c15b16b2b399f5ce30691e744622b · passbolt/passbolt_packaging · GitHub

You could post a new Feature Request here in the forum and we welcome that to help track interest on things like this.