Domain problem passbolt

My domain to enter in Passbolt is passbolt.krack360.com. The problem is that this is not the correct domain name. In new devices and browsers it doesn´t go


So I have to write this to login:

https://passbolt.krack360.com/auth/login?redirect=%2F&locale=en-UK

In the next cases I will only need to write passbolt.krack360.com because automatically it writes:

https://passbolt.krack360.com/auth/login?redirect=%2F&locale=en-UK)

Probably due to cache.

I don´t know what to do to change this to write only passbolt.krack360.com

Thank you

Hi,

I guess you still have /etc/nginx/sites-enabled/default.conf file on your Ubuntu server. It is the default config of nginx, you can delete it:

sudo rm /etc/nginx/sites-enabled/default.conf

Then reload nginx:

sudo systemctl reload nginx

Then you will have only passbolt virtualhost enabled. One other thing you can try is to check if ssl force is set to true in passbolt section of your /etc/passbolt/passbolt.php file:

    'passbolt' => [
        // GPG Configuration.
        // The keyring must to be owned and accessible by the webserver user.
        // Example: www-data user on Debian
        'gpg' => [
            // Main server key.
            'serverKey' => [
                // Server private key fingerprint.
                'fingerprint' => 'xxxxxx',
                'public' => CONFIG . DS . 'gpg' . DS . 'serverkey.asc',
                'private' => CONFIG . DS . 'gpg' . DS . 'serverkey_private.asc',
            ],
        ],
        'registration' => [
            'public' => false,
        ],
        'ssl' => [
            'force' => true,
        ]
    ],

Best,

1 Like

But now I have this error

Shoud I do dpkg-reconfigure passbolt-ce-server ?

Ok this is only the first time. The first time in the browser I have to write https://passbolt.krack360.com, the next times I can write passbolt.krack360.com and it automatically redirects