Email creation doesn't sent, email test not working and the section EmailTransport doesn't exist

I have created a new accout and the mail doesn’t sent. The test mail not working : “Could not send the test email.
Error: stream_socket_client(): unable to connect to tcp://mydomain:587 (Connection refused)”
I have seen : Passbolt Help | Why are my emails not being sent? and Passbolt Help | Configure email providers
In my passbolt.php the section ‘EmailTransport’ does not exist and I don’t where to paste it.
I didn’t mention it but I use gmail smtp

If you are using Gmail smtp, and it’s not a workspace related account, did you establish 2fa with Google on the account and create an app password as a stand in for the password? Gmail blocks use of main password.

Some settings are being moved to the admin gui in combination with database storage. They may not appear in passbolt.php anymore.

I didn’t establish 2fa with google or other app.

Once you set up 2fa on the Google account, scroll ALL the way down on the 2fa settings page and you’ll see an option to create an app password.

1 Like