Error at app.fullBaseURL

Hello,

Thx for the nice job with passbolt.

I’ve follow this:

But at the step 4 to Wrapping up i have this error.

Thx for help :wink:

`[PASS] Debug mode is off.

[PASS] Cache is working.

[PASS] Unique value set for security.salt

[PASS] Unique value set for security.cipherSeed

[PASS] Full base url is set to http://10.80.3.35

[PASS] App.fullBaseUrl validation OK.

[FAIL] Could not reach the /healthcheck/status with the url specified in App.fullBaseUrl

[HELP] Check that the domain name is correct in app/Config/core.php

[HELP] Check the network settings`

*/
Configure::write(‘App.fullBaseUrl’,‘http://10.80.3.35’);

/**

Hi Arkaine,

This looks like it could be a url rewriting issue. Could you send a screenshot of what happens when you manually try to access http://10.80.3.35/healthcheck/status ?

Did you configure nginx as mentioned in the article? Did you restart it / or reload it after ?

Hi Kevin,

Yes i have reload the service.
Some apache user have the same error and they activate apache rewrite.

When i try to access http://10.80.3.35/healthcheck/status i have a timeout error.


 ____                  __          ____
/ __ \____  _____ ____/ /_  ____  / / /_

/ // / __ `/ / / __ / __ / / _/
/ / // ( |
) /
/ / /
/ / / /
/
/ _
,
/
//.__/__//_/

Open source password manager for teams

Healthcheck shell

Environment

[PASS] PHP version 7.0.25
[PASS] PCRE compiled with unicode support
[PASS] The temporary directory and its content are writable
[PASS] The public image directory and its content are writable

Config files

[PASS] The core config file is present
[PASS] The database config file is present
[PASS] The email config file is present
[PASS] The application config file is present

Core config

[PASS] Debug mode is off.
[PASS] Cache is working.
[PASS] Unique value set for security.salt
[PASS] Unique value set for security.cipherSeed
[PASS] Full base url is set to http://10.80.3.35
[PASS] App.fullBaseUrl validation OK.
[FAIL] Could not reach the /healthcheck/status with the url specified in App.fullBaseUrl
[HELP] Check that the domain name is correct in app/Config/core.php
[HELP] Check the network settings

SSL Certificate

[FAIL] SSL peer certificate does not validate
[FAIL] Hostname does not match when validating certificates.
[WARN] Using a self-signed certificate

Database

[PASS] Configured to use a supported database backend
[PASS] The application is able to connect to the database
[PASS] Not using a prefix for database tables
[PASS] 20 tables found
[PASS] Some default content is present
[PASS] The database schema up to date.

GPG Configuration

[PASS] PHP GPG Module is installed and loaded
[PASS] The server gpg key is not the default one
[PASS] The environment variable GNUPGHOME is set to /var/cache/nginx/.gnupg
[PASS] The directory /var/cache/nginx/.gnupg containing the keyring is writable by the user the webserver is running as.
[PASS] The public key file is defined in app/config.php and readable.
[PASS] The private key file is defined in app/config.php and readable.
[PASS] The server key fingerprint matches the one defined in app/config.php.
[PASS] The server key defined in the app/Config.php is in the keyring.
[PASS] There is a valid email id defined for the server key.
[PASS] The public key can be used to encrypt and sign a message.
[PASS] The private key can be used to decrypt a message.

Application configuration

[PASS] Using latest passbolt version (1.6.5)
[FAIL] Passbot is not configured to force SSL use
[HELP] Set App.ssl.force to true in app/Config/app.php
[FAIL] App.fullBaseUrl is not set to HTTPS
[HELP] Check App.fullBaseUrl url scheme in app/Config/core.php
[PASS] Selenium API endpoints are disabled.
[PASS] Search engine robots are told not to index content.
[PASS] Registration is closed, only administrators can add users.
[PASS] Serving the compiled version of the javascript app
[PASS] All email notifications will be sent.

Development Tools (optional)

[PASS] Phpunit is installed
[PASS] Phpunit version is 3.7.38

5 error(s) found. Hang in there!

What happens when you try to access http://10.80.3.35 ? Do you see a passbolt page ?

Nop ;( Timeout when i try to access

It could be a network issue. Can you ping 10.80.3.35 ?

Yeep i can ping the address.
i have a clue with port query
TCP port 80 (http service): FILTERED on 10.80.3.35

Ok, i find the problem
FirewallD -_-"

http://10.80.3.35/ --> 403 Forbidden
http://10.80.3.35/healthcheck/status —> 502 Bad Gateway

2017/11/27 13:29:04 [error] 1530#1530: *1 directory index of "/var/www/passbolt/" is forbidden, client: 10.80.100.210, server: , request: "GET / HTTP/1.1", host: "10.80.3.35"

2017/11/27 13:33:19 [error] 1530#1530: *4 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 10.80.100.210, server: , request: "GET /healthcheck/status HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "10.80.3.35

There is no solved
I need to find the problem with nginx now :wink:

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.