Experiencing error "Cannot read property '1' of null" on login

#1

Hello,

since yesterday we can’t login into Passbolt. We are getting this error message:

Can you please help me?
Thank you, Michal.

#2

Hello Michal,

Could you tell me more about your environment :

  • Browser type and version ?
  • Passbolt version ?

Can you provide us with the browser debug console. To open the browser debug console, please follow the following doc :
Firefox: https://developer.mozilla.org/en-US/docs/Tools/Browser_Console
Chrome: https://stackoverflow.com/a/10258029/4063145 (The background page here is index.html)

Note: We are currently deploying a new version of the plugin, it could be related. Can you try to restart your browser and try again if it is not done yet.

Best regards,
Cedric

#3

We’re experiencing the same error since today.

Browser: Chrome 73.0.3683.103
Passbolt Version: 2.1.0/2.9.1
Extension: 2.9.1

Output Chrome Extension Console:

#4

Browser - Google Chrome Verze 73.0.3683.103
Passbolt - Plugin 2.9.0/API 2.0.7

Console without errors.

Still not working after restart.

#5

Thank you for your feedback @tobi and @grave

I can reproduce it with a v2.1.0. The backward compatibility has been broken with API < v2.2.0.
We are working on a fix and we’ll keep you posted.

Note that the versions of the API you are using are almost one year old. We do encourage you to update your passbolt. You can find more information here: https://help.passbolt.com/hosting/update.

#6

I updated it and it works, thank.

But after upate I have
[FAIL] The public key cannot be used to verify a signature.

in healthcheck.

#7

A new version (v2.9.2) of the browser extension has been released and fix this backward compatibility issue with API < v2.2.0. Google and Mozilla are currently rolling out the new version and it can take time. You can manually force the update of the plugin if your need to access quickly your passwords.

1 Like
#8

@grave [FAIL] The public key cannot be used to verify a signature.
This is known to us and this warning should not be.
I just created a ticket on github to tackle and follow-up on this issue.

#9

Thanks a lot, I will pass this issue to our dev, so they can provide more specific info about environment where we run our instance of passbolt.

1 Like
#10

Thank you so much, now it works fine!

1 Like
Match is Null error. Passbolt not working after restart
#11

We do invite you to update your passbolt API as soon as you can! :slight_smile:

closed #12

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.