Firefox extension on new laptop does not show recovery interface

I switched to a new Laptop and can’t get the Passbolt plugin running on firefox 96.0.2.

Issue description.

  • I see that the plugin is downloaded and installed. There is the usual icon showing the in the toolbar.
  • This icon stay’s gray. It does not activate and a click routs me to Passbolt | How would you like to use passbolt?
  • I don’t get the pop-up with the setup to enter my passphrase as described in 3.2 Passbolt Help | Install Passbolt CE on Ubuntu 20.04
  • When I call our usual passbolt server URL, I’m routed to the firfox download passbolt plugin site that offers me to remove the plugin. It’s a dead end.

System:
firefox is already the newest version (96.0+build2-0ubuntu0.20.04.1).
Running on Ubuntu 20.04.3 LTS

I tried so far:

  • Removing & reinstalling the plugin
  • restarting firefox
  • F5 to refresh
  • I tried the firefox account synchronization to get my configuration from the old laptop to the new one. It installs the plugin, but it gives the same non-functional behavior.
  • I deactivated all other plugins and tried to run the passbolt plugin in standalone. No improvement.

Checklist
[ x ] I have read intro post community.passbolt…
[ x] I have read the tutorials, help and searched for similar issues
There was just one with an outdated browser. Which is not my case.
[ x ] I provide relevant information about my server (component names and versions, etc.)
I’m running a self hosted passbolt version on a cloud. Other people in our team can access the server as usual. I also can access it from my old laptop. It’s the second time this issue appears when one of our team members switches a laptop.
[ x ] I provide a copy of my logs and healthcheck
Not relevant. Server is up and running.
[ x ] I describe the steps I have taken to trouble shoot the problem.
See section above.
[ x ] I describe the steps on how to reproduce the issue

  • Use a new laptop to install the firefox plugin on an already existing passbolt server (selfhosted cloud) and account.

Hi @gre Welcome to the forum and sorry you are having trouble.

With a new device, the browser extension will need to be reinstalled. I may be misunderstanding, but you say your site redirects you to remove the extension and this leads me to believe you already have it installed. Try uninstalling the extension, and then going to your site fresh.

It should not automatically redirect but instead tell you you need to install it. More importantly, you will then need to recover your account once you return back to your site. This includes using your private key to associate the new laptop browser with your site.

Hope this helps.

Hey @garett,
thanks for the reply. I already tried that step of uninstall/install/refresh on the new laptop. It didn’t help. That is the dead end issue I face. The plugin gets installed but it does not work properly. You understood correct my passbolt cloud server “… site redirects you to remove the extension and this leads me to believe you already have it installed…”

I have the key’s ready to use, whenever the plugin starts to work and prompt a key request.

OK, well that’s pretty frustrating!

Would you mind confirming your passbolt server version? We’ll assume the latest version for the extension.

Also, what version of Firefox are/were you running on the old machine (assuming you still have it)?

Hey @garrett,
The passbolt installation is on version 2.13.5.
My old laptop had a firefox up to date with the 96.x version. There were regular updates installed. I can double check this later to be sure.

// We had this issue before when team member changed laptops in Feb 2021. Since then we had no updates on the passbolt version, only on browser versions.

Hi @gre

Your passbolt version is too old. The home page of the application has evolved and the legacy API v2.x home page doesn’t display the link to recover your account anymore.
You have 2 options:

Don’t hesitate if you have further questions.

Best,

Hi @_jc ,
the recovery Link worked.
The plugin started to work now and I can access our passbolt server again, even without the update.
However, we will upgrade the server asap.

Thanks for your support.
Best, Gre

1 Like

Cool ! Don’t hesitate to come back here if you have questions about passbolt upgrade.

Best,