"Generate a new password securely" feature does not work

We’ve been using Passbolt for a little over a year now. My team has accepted it over our previous solution, 1Password, because it’s more secure being stored on our own servers than in the cloud, and it’s more flexible. However, there’s a feature I just tried that doesn’t work and others on my team have reported it as well to me, but this is my first time experiencing it.

When you’re on a website setting up a new account, one of the options when you are establishing a password for the site states:

**Generate a new password securely**
You will be able to save it after submitting

… so I do so. And it fills in the generated password into the password and confirm fields, and then I click Continue/Submit on the website. I’m now logged into the website. But at no time does Passbolt save the password or give me the option to copy it into a new entry for this website. When I log out, I’m left without the password that Passbolt generated.

My request:

  • If this feature works and I’m doing it wrong, please say so and tell me how I should be doing it.
  • If the feature does not work, please fix it, or remove it from Passbolt until it does work.

It seems this topic may have come up before. I did some search engine research before coming here and posting. I found this:

Based on this post, it seems that (perhaps at the time, and perhaps this isn’t true now) Passbolt would not prompt you to save the password like a browser-based password manager would. But being that it’s now 3 years later, my assumption is that this has been taken care of by now.

FYI, my version and relevant info:

  • Firefox 125.0.3 (I’ve tried in Chrome, it happens the same way there)
  • Passbolt Firefox Extension 4.6.2 (2024-04-19)
  • Passbolt CE 4.7.0-1 running on Ubuntu Server 22.04.4 LTS (standard apt install, no docker/kubernetes/etc.)

Steps to reproduce problem:

  1. Go to a site you’ve never been to before that prompts for a new password and confirmation.
  2. Right click on the Passbolt icon in the right side of the password field and select “Generate a new password securely”.
  3. Scratch head. Wonder what password it just set you up with.

As always, thanks for all you do. As an open-source developer, I understand how much time and dedication goes into every open source project.


Step 3. should be: submit form and login in the site. Then a popup of the “quick access” opens with the generated password and other details, that you should then be able to save in passbolt. (See screenshots)

Does it happen on all sites? Does it happen also with another browser?
I will check if this is an issue we can manage to reproduce and fix.

@anomaly0617 I had a quick check in with the developer who worked on this and they say it’s possible that the event that corresponds to the form submission may not be cought for some sites. If you have some examples of URLs where it doesn’t work for you that would help us to reproduce and schedule a fix.

Thank you again for your support and kind words, they are much appreciated.

1 Like