Getting mysql error installing on Ubuntu server [use for local install]

I am using Hyper-V and have installed the latest Ubuntu server minimzed installation.

I am installing the CE version, after running the installer and getting to the point were it asks me to “provide the domain name where you will run passbolt”, I have tried both the FQDN and the IP address then I get error:

mysql: [warning] using a password on the command line interface can be insecure.
ERROR 1045 (28000): Access denied for user ‘admin3g’@‘localhost’ (using password: YES)
dpkg: error processing package passbolt-ce-server (–configure):
installed passbolt-ce-server package post-installation script subprocess returend error exit status 1
Processing triggers for nginx-core (1.18.0-6ubuntu14.3) …
Triggering nginx reload …
Errors were encoundered while processing:

I tried rebooting the server, and running the installer again, simplifying the passswords on mysql, and like I said I have tried to use the FQDN and IP address in the ngix setup; our Windows DNS server has an entry for the FQDN for this server.


hey @3GLighting welcome to the forum.

Based on the error this looks like an issue with your MySQL password and not so much an issue with the FQDN vs IP for the nginx setup.

Are you able to connect to the database from the command line of the passbolt server?

Hi @clayton,

In short, no. After I get that error the setup fails and returns me to the command line.

Ah sorry for not being more clear, I meant are you able to manually connect to the database after it kicks you back to the command line, so by running:

mysql -u admin3g -p

It’ll then prompt you for your MySQL password

Yeap it fails with both my original password and the password I used the second time around.

So since you can’t log in to the database with the admin3g user that is going to be the cause of the error. You have a couple options to sort this out

  • Log in to the database with the root user and change the password for admin3g
  • Log in to the database with the root user and create a new user to use to connect with
  • Since it is still early in the install process, start over with a new clean vm

I will re-do the VM again… about about the 3rd time.

I tried logging in as my admin login for Ubuntu but that failed.

WIll let you know how it goes…


So now after reinstalling it didn’t set my root password correctly on my DB but it did setup the username correctly; I don’t know why MySQL doesn’t prompt you twice for the root password as it does for the user password. (Sigh)

I am in the Website now, but it won’t accept my user login for the DB. :frowning:

I have tested the user login using your mysql -u username -p and it works.



I suspect part of the issue from the beginning is that mysql was not installed and ready to go before installing passbolt. The package doesn’t handle simultaneous mysql installs or upgrades very well.

In the event of these errors on a package update, for example, if mariadb is also updating it will produce similar results. Running apt dist-upgrade again is typically what is needed in those moments.

The reason command line access is not permitted is because access to mariadb by default is session based so just running mysql as root without password would be enough to get you in.

With mariadb installed, I believe running mysql_secure_installation can address the issue of not being able to use passwords.


  • You can set a password for root accounts.
  • You can remove root accounts that are accessible from outside the local host.
  • You can remove anonymous-user accounts.
  • You can remove the test database, which by default can be accessed by anonymous users.

You could maybe try installing mariadb first, running the command above to establish db user root with a password, and then installing passbolt-ce package where you can provide the credentials you already established. The package is designed to install mariadb as part of the process, but something there may not be working right.

Hi @garrett

There is no mention of needing to install it here:

Hence why I didn’t install it and assumed that Passbolt would install it.


You are correct!

I am noticing it says If not instructed otherwise passbolt ubuntu package will install mysql-server locally. This step will help you create an empty mysql database for passbolt to use.

The content on these pages is updated as needed so let us know if the steps above work for you.

And I forgot to mention I can log into mysql on the Ubuntu server using the user account, not the admin account. I rebuilt the server and just like in the instructions created a user called root but missed the part about the blank password and set the password to hiway2020 and after it installed I could not log into mysql using root/hiway2020 I tried to leave it blank just in case and that failed too.

But I will try your steps tomorrow when I am in the office and report back after I do a fresh rebuild again… 5th time. :slight_smile: \

I thought I locked myself out of a db the other day - different app but same kind of thing. Sorry it hasn’t gone more quickly for you but what you are describing sounds right and I hope it works!

I also notice the notes don’t say anything about HDD size in the above install guide for Ubuntu 22.04 I posted above. So I guess the default 128GB HyperV set the VM to is OK? :slight_smile:

@3GLighting Minimum requirements posted have previously ranged from 50GB to 10GB…the real size needed of course depends on your use case. The app itself is not large.

128GB is far beyond any kind of minimum requirement, yes.

I have been installing the Ubuntu (minimized) version previously. I am installing the full server this time, should I still run your sql stuff before installing passbolt?

Let me know,


@3GLighting On a fresh server, the package is expected to be able to handle the mariadb install. I would still attempt to let it do so as a first approach. If it has trouble, then the previously mentioned issue of simultaneous mysql updates might be kept in mind.

OK, so it looks more like the document when I install it now however once I am in it wants me to setup the database; not sure why if it does this during the installation.

So I gave the DB the servers IP address, and the root login and password and the db name ; passboltdb but it errors out saying “a connection could not be established with the credentials provided. please verify the settings.”

I tried the passboltadmin account and the FQDN for the server IP address and it still doesn’t work. I also did mysql -u passboltadmin -p and put in the password and it accepted it in command line.


(post deleted by author)

The package will perform only a local mariadb installation. If you have a remote db, then you will want to set it up ahead of time.

And if I am misunderstanding and your db is local, then the setup will use localhost at

If this is confusing, maybe note the step you are on for clarity.

The package install != app install. Package install gets the dependencies in place. The app installation gets the admin and keys in place (with some overlap).

1 Like