How to configure SSL after Installation


I just installed Passbolt, created a user and tested some feautures. I really like Passbolt so far!

During my installation, I choose not to have a SSL-Certificate because the domain is not public, only for the company I work for. So I got error messages when I tried to generate a Cetificate with LetsEncrpyt.

But right now, after I did some testing, I want to add a SSL-Certificate and change the URL from http:// to https://.

I tried it in the Debian Terminal with /etc/passbolt/passbolt.php but I get the message “command not found”

I will give you more insights, if you need them!
Thanks for your help!

Hello @GLE,
I’m glad that you like passbolt. :love_you_gesture:

Regarding the SSL reconfiguration, since you’ve mentioned being on Debian, you can run:

sudo dpkg-reconfigure passbolt-ce-server

If you already have a database configured you can select No and move to the nginx part where depending on the SSL certificate you can chose manual or auto :wink:

1 Like

Hi and thank you!

It worked - I selected our SSL Cert. and our private key.
Now I get the message "Well done! Visit https://XXX to finish installation.

But right now, I get an Errormessage, when I try to go to that site.
I guess this is because our Database is still reachable via http.

How do I change the URL to HTTPS?
I tried it with /etc/passbolt/passbolt.php but it either says I have no permissions or it says “command not found”. (If it do it with sudo)


Ok I just reloaded my VM and now the http URL doesnt work anymore. I get the message “Welcome to Nginx!”

When I open HTTPS, I get an Empty page…

I have Snapshots of my VM. I can easily go back. Where did I make a mistake?

Best regards

What was the error message?

Could you explain what you tried here? Like did you try to open this with vim or nano?

I went back to a Snapshot to try it again. This is what I did now:

I saved the public and private key, downloaded the SSL cert and key from our PFSense and did sudo dpkg-reconfigure passbolt-ce-server

I said NO to the MYSQL Setup question and choosed “manual” at the Ngnix setup question.

I typed in my localdomain pdmanager.cocolab and selected the path where the cert and key is. Then I get the “Well done! https” message.

before I restart the VM, I get the message “Unable to connect” and the http URL still works.

I read somewhere that I have to change the fullURL in /etc/passbolt/passbolt.php

Nothing happend there.

I have no experience with Debian, so its possible I did something wrong there.

Alright, after you run sudo dpkg-reconfigure passbolt-ce-server you do have to make an edit to the /etc/passbolt/passbolt.php file. For this you’ll need to use a text editor such as vim or nano, if you are not familiar with Debian nano is probably better to use for this.

I have GNU nano 7.2 installed. Can I edit /etc/passbolt/passbolt.php now?

yea you should be able to

Ok thanks. I try to figure out how to do this.

Im gonna reply if i know more.

1 Like