How to remove the "unsafe mode" flag at the bottom right corner?

Hello, I am new to passbolt, I installed it on my home server under esxi and it is very useful, very fast and very simple to use.
I would have only one question to ask you; at the bottom right the word “unsafe mode” appears. I honestly don’t know how to disable debugging way because I don’t know which file to edit.
I installed passbolt on centos 7.
Many thanks in advance


Welcome to the passbolt community!
The unsafe mode can come from two reasons:

  • You have debug mode on
  • You are not using passbolt with HTTPs

By default debug mode is off unless you switched it on in your passbolt directory on the server under config/passbolt.php. (Search for 'debug' => true)

Thanks so much for your reply.
Unfortunately in /var/www/passbolt/config/passbolt.php there isn’t the “debug” option.

ok I find the problem. I don’t use https so the system show me the alert.

Thanks so much

@ohifra can you confirm you are using https?

the problem is that I don’t use https.
Thanks so much for your help

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.