I tried to install in an ubuntu server 22.04.2 i get this Error

Please Help!!!


It seems port 80 is closed on your server. You should open it to be able to use Let’s Encrypt.


How do I do that
I have purchased hosting for that domain

Hi @ritesh

If you are using a server at home, open port 80 on your router/gateway. If you are using remote vps, you should email the hosting company and ask them to open port 80. If you setup UFW here is some stuff from LinuxBabe.

sudo ufw allow 80/tcp

sudo ufw allow 443/tcp

If you are using UFW you should have logging on

sudo ufw logging on

sudo ufw logging medium

To check status

sudo ufw status
sudo ufw status verbose

To check ports

Install nmap on your Debian/Ubuntu/Linux Mint server and scan opened ports on the public IP address. Replace with the actual public IP address of your server.

sudo apt install nmap

sudo nmap

Thank You and one more Doubt where my domain should point to the public ip of the server ??

Correct, your domain should generally be pointing to the public IP of the server. Will you be hosting as a subdomain? For example are you hosting this as:

  • passbolt.somedomain.tld
  • somedomain.tld

No i have my own domain and should add A record to my server public ip

1 Like

i will be hosting as somedomain.in

You should add an A record to your DNS zone and the public IP of the server that hosts Passbolt.
For example somedomain.in IN A

Should the status should be active or inactive

Can some help me with procedure i trying from past 3 days couldn’t figure it out
What i want to do:
I have raspberrypi which runs ubuntu server in it and I have my own domain
I want host pass bolt through my domain

The general procedure given in hosting page of pass bolt isn’t working for me

Just to be clear here. You are running ubuntu 22.04 on a raspberry pi and trying to set it up to be accessible from outside of your home network with your domain name?

and tried to open ports using above cmd but couldn’t

Yes this is what I am exactly trying to do… but didn’t get any success so far

Ah alright, I think most advice here was assuming this was a VM with a hosting service so had a public IP that you could ping from outside of the home network.

I think most people who are running their passbolt at home are using a cloudflare tunnel to access it outside of their home network. Is this something you have set up already?

Yes i do have this setup

sir can u help ??
I have trying from past 3 days

Hi @ritesh

I understand your frustrations. Keep at it, you are doing great. Setting up a server is not easy work.

It sounds like your home router needs to be setup to communicate with your Pi. Please click the link below that might help solve the port issue. If the link does not help, you might need to contact your ISP (your internet service provider).

UFW is a firewall you can setup on your server (Pi) to add security. If you want to use UFW, then it should be enabled. If it disable, then you are not using it. It was just an idea of something that could be blocking ports 80 & 443 for you.


1 Like