Installation issues

I install passbolt on my website isec.8ty6.co when I trying
PHP GPG Module is installed and loaded. but showing
“The environment variable GNUPGHOME is set to /home/wbadmin8ty6/.gnupg, but the directory does not exist.”

Hi @pritesh and welcome to Passbolt Community Forum :handshake:

According to your screenshot, I guess you are using a CentOS 7. Did you installed Passbolt following Passbolt Help | Install Passbolt CE on CentOS 7 ?

If yes, did you encounter any issue ? Is your server a fresh server without anything else ? Do you have selinux enabled ?

By default, GNUPGHOME is set to the web server home path.

I guess there is something wrong with your nginx user permissions.

yes i am using CENTOS 7.9 kvm [fete5]

Did you try to login as wbadmin8ty6 user and launch this command ?

gpg --list-keys

It will create your missing folder.

Thanks _jc .
pass bolt installed but not sending emails

Hi @pritesh, you will find email troubleshooting how-to here: Passbolt Help | Why are my emails not being sent?

hello @_jc when i run this

$ ./bin/cake passbolt send_test_email --recipient=youremail@domain.com

It showing email send successfully but I don’t get any email

Hi,

Can you send the full output of the command ?

Thanks :slight_smile:

[wbadmin8ty6@fete5 isec]$ ./bin/cake passbolt send_test_email --recipient=pritesh.sarda@8ty6.co

 ____                  __          ____
/ __ \____  _____ ____/ /_  ____  / / /_

/ // / __ `/ / / __ / __ / / _/
/ / // ( |
) /
/ / /
/ / / /
/
/ _
,
/
//./_//__/

Open source password manager for teams

Debug email shell

Email configuration

Host: mail.8ty6.co
Port: 587
Username: notification@8ty6.co
Password: *********
TLS: true
Sending email from: isec 8ty6 notification@8ty6.co
Sending email to: pritesh.sarda@8ty6.co

Trace
[220] fete5.8ty6.co ESMTP Exim 4.94.2 #2 Tue, 05 Oct 2021 02:27:02 -0700
[220] We do not authorize the use of this system to transport unsolicited,
[220] and/or bulk e-mail.

EHLO localhost
[250] fete5.8ty6.co Hello localhost [162.213.253.150]
[250] SIZE 52428800
[250] 8BITMIME
[250] PIPELINING
[250] PIPE_CONNECT
[250] AUTH PLAIN LOGIN
[250] STARTTLS
[250] HELP
STARTTLS
[220] TLS go ahead
EHLO localhost
[250] fete5.8ty6.co Hello localhost [162.213.253.150]
[250] SIZE 52428800
[250] 8BITMIME
[250] PIPELINING
[250] PIPE_CONNECT
[250] AUTH PLAIN LOGIN
[250] HELP
AUTH PLAIN AG5vdGlmaWNhdGlvbkA4dHk2LmNvAEN4NG0mNGlHdC5DTA==
[235] Authentication succeeded
MAIL FROM:<>
[250] OK
RCPT TO:pritesh.sarda@8ty6.co
[250] Accepted
DATA
[354] Enter message, ending with “.” on a line by itself
From: isec 8ty6 <
>
To: pritesh.sarda@8ty6.co
Date: Tue, 05 Oct 2021 09:27:02 +0000
Message-ID: ad1d25b0337442ad82ccc9039835c998@fete5.8ty6.co
Subject: Passbolt test email
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Congratulations!
If you receive this email, it means that your passbolt smtp configuration is working fine.

.
[250] OK id=1mXgj1-00028G-Ea

QUIT
The message has been successfully sent!
[wbadmin8ty6@fete5 isec]$

when i run this
./bin/cake EmailQueue.sender
i got mail only on this admin email( notification@8ty6.co)
not other mails ids

Hi, the send_test_email command show us than the mail has been sent to your mail.8ty6.co server on port 587.
At this point, you should have a look at mail.8ty6.co Exim logs, as it seems this server uses Exim as MTA. You should have a look at your spam folder too.

this cronjob is right or wrong

/usr/local/bin/php /home/wbadmin8ty6/public_html/platform/isec/bin/cron >> /var/log/passbolt.log

Hi,

A cronjob must contains a cron schedule expression. You can use https://crontab.guru/ to test it.
But as Passbolt cron job must be run every minute, this expression must be * * * * *

You must edit the cronjob as the web server user who will execute this cronjob:

$ sudo -H -u replace-this-with-your-nginx-user crontab -e

Add your cronjob as follow:

* * * * * /bin/bash /root/path/to/passbolt/bin/cron

If you look at Passbolt source code, you will see than the cron task script is a bash script: passbolt_api/cron at master · passbolt/passbolt_api · GitHub so it cannot be launched with php.

Another remark, if you execute the cron script as your nginx user, and if you want to redirect output of cron to /var/log/passbolt.log, you should take care to filesystem rights as this user won’t be able to write to this file without set proper rights before.

You can create this file and set correct rights like this:

$ sudo touch /var/log/passbolt.log # if this file doesn't exist
$ sudo chown your-nginx-user:your-nginx-user /var/log/passbolt.log

Best,

whan i command this on terminal I got error

bash: ./bin/cake: Permission denied

Hi,

This command must be executed as the user who is running the nginx server. It is usually the nginx user on CentOS7 and www-data on Debian family distros.

This command should work for you:

sudo su - nginx -s /bin/bash -c "/var/www/passbolt/bin/cake EmailQueue.sender"

im trying this command but i get error wbadmin8ty6 is not in the sudoers file. This incident will be reported.

If your current user is not in sudoers file, execute the command as root user :slight_smile: