Installed successfully - Now can't log in

#1

Had just finished installing and configuring Passbolt, was logged in and on the main dashboard.
Switched users in Chrome and noticed my Passbolt tab close.
Reopened my instance and found that I’m unable to login.

The “Recover your account” option supposedly sends an email but there’s nothing in my inbox or spam folder.

My Chrome extension for Passbolt is also suddenly apparently unconfigured now and I have no idea how to reconfigure it.

What can I do here?

0 Likes

#2

Hello @skunkworks,

Switched users in Chrome and noticed my Passbolt tab close.

Chrome creates independent environments for each user to allow them to customize chrome as per their will. This is an expected behavior that your user doesn’t have access to the data of the other users.

The “Recover your account” option supposedly sends an email but there’s nothing in my inbox or spam folder.

Your email server is probably wrongly configured. Passbolt offers a command line tool to help you configure your email server, did you see the online documentation relative to this point : https://help.passbolt.com/faq/hosting/why-email-not-sent

Once your email server will be correctly configured you will be able to recover your account.

0 Likes

#3

Passbolt offers a command line tool to help you configure your email server, did you see the online documentation relative to this point

I had not. But when I try to run $ ./bin/cake passbolt send_test_email --recipient=youremail@domain.com after logging in as root I get “command not found”

I went to the bin folder and looked for a “cake” folder and found that no such folder existed in /bin. (Insert “The cake is a lie” joke here.)

Any other ideas?

0 Likes

#4

Hi @skunkworks!

Maybe it’s a bit misleading but all the paths are referring to passbolt base installation directory. Which in the case of the digitalocean image are /var/www/passbolt if I recall correctly. Also it is good to test all the passbolt stuff as the web user which in this scenario is www-data:

So:
$ cd /var/www/passbolt

$ sudo -u www-data -s

$ ./bin/cake passbolt send_test_email --recipient=youremail@domain.com

Hope this helps!

1 Like

#5

the paths are referring to passbolt base installation directory. Which in the case of the digitalocean image are /var/www/passbolt if I recall correctly.

Aha! There we go. Command works now.
I got an SMTP timeout error.

Host: smtp.gmail.com
Port: 465
Username: myemail@domain.com
Password: **************
TLS: true

All settings looked correct to me but I edited config/passbolt.php and changed the port to 587 and tried again.

This time I got the error

A test email could not be sent.
Error: SMTP server did not accept the password.

I double checked that I was using the correct password for the account in question and I am indeed using the correct password.

Hmm now what? (I’m currently investigating if there’s some GSuite setting preventing using SMTP from the Passbolt server.)

0 Likes

#6

Google account setting was preventing Passbolt from emailing.

I’ve recovered the account and am back into my instance.

Thanks for the help.

0 Likes

closed #7

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.

0 Likes