Issue with Firefox 57 and Accept third-party cookies disabled


Does anyone have experiences with FF 57 (aka Quantum)?

I have an issue that everything works nice with Chrome but I cannot log in with Firefox:

All looks nice, the right color, Server ID and the mnemonic is correct and I am using the right password. After entering my password it takes some seconds and I am back in the login screen.

At first I thought our own server is to be blamed but it’s the same with the original passbolt demo.

Any ideas how to resolve it?

As a quick note: The Passbolt extension works fine for us over here with Firefox 57 (64bit, Linux).

Thanks a lot! I forgot to mention that this is with MacOS (and there one finds quirks that unheard of on windows or linux).

I will try to test more systems/browsers/versions…

@bolzer while developing I experienced this issue. Deleting the cookies in the cache solves it for me. Let me know if this works.

@remy Nay, that didn’t work (my settings delete any cookies after closing. I tried anyway but no success). I have 3rd party cookies disallowed but I guess that is not a problem here, is it?

Still have to try other versions at home… will keep trying.

@bolzer yes third party cookies shouldn’t be disabled, or at least you should allow 3rd party cookie from your passbolt domain.
This is due to the fact that some calls are made from moz:// urls and not https://passbolt urls, e.g. API calls made by the extension used cookies to authenticate.
The browser needs to accept passbolt domain to use cookies from this moz:// scheme.
You don’t have to whitelist them all, just your domain. See

Ah yes, you just beat me to it, just figured that out by trying:

With Accept third-party cookies enabled it works. I was wondering why there would be just one cookie CAKEPHP but I will read up your link.

Thanks :slight_smile:

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.