JWT Authentication warning

I ran HealthCheck on my Passbolt server and everything passes except

BlockquoteJWT Authentication

[WARN] The JWT Authentication plugin is disabled
[HELP] Set the environment variable PASSBOLT_PLUGINS_JWT_AUTHENTICATION_ENABLED to true

Where do I find this environment variable?

Hi @DaddyWarlock,

The message displayed is a warning, it is not an error. We might consider displaying an information message, rather than a warning, if this is disturbing.

If you are interested in using JWT authentication, you can set the environment variable PASSBOLT_PLUGINS_JWT_AUTHENTICATION_ENABLED to true. Let us know if you do not know how to do that.

If you are not interested in using JWT authentication, you can ignore this message.

That’s exactly what I’d like to do. Where do I find this environment variable?

I found it by using this command:

grep -rnw /var/www/passbolt -e "PASSBOLT_PLUGINS_JWT_AUTHENTICATION_ENABLED" 2>/dev/null

It was in /var/www/passbolt/config/default.php

Thanks! That’s a big help.

The “passbolt way” to enabled plugins is to either play with the passbolt.php if you are not using a container.
In order to do so, here is an example of how to enable JWT authentication and mobile transfer (iOS beta version will be out this week)

return [
    // [...]
    'passbolt' => [
        'plugins' => [
            'mobile' => [
                'enabled' => true
            ],
            'jwtAuthentication' => [
                'enabled' => true
            ],
        ],
    ],
];

Max,

I tried your code snippet but I’m still getting

      "The JWT Authentication plugin is disabled"

when I run Healthcheck.