My setup(v2) is loosing users / PWs inserted by GUI

Dear team,
our passbolt-installation is accepting neither new passwords nor users created over the webgui.

  • The user / passwort is shown in gui for a few seconds. After a change of webpage / refresh the data is gone.

User creation over CLI is possible and working.

My setup:
VM on Ubuntu 16.04.4 LTS
mysql Ver 14.14 Distrib 5.7.21, for Linux (x86_64) using EditLine wrapper
PHP 7.0.28-0ubuntu0.16.04.1 (cli) ( NTS )
Copyright © 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright © 1998-2017 Zend Technologies
with Zend OPcache v7.0.28-0ubuntu0.16.04.1, Copyright © 1999-2017, by Zend Technologies
Passbolt v2.1 (updated from newest 1.x)

www-data@test:~$ /var/www/html/passbolt/bin/cake passbolt healthcheck

 ____                  __          ____
/ __ \____  _____ ____/ /_  ____  / / /_

/ // / __ `/ / / __ / __ / / _/
/ / // ( |
) /
/ / /
/ / / /
/ _

Open source password manager for teams

Healthcheck shell


[PASS] PHP version 7.0.28-0ubuntu0.16.04.1.
[PASS] PCRE compiled with unicode support.
[PASS] The temporary directory and its content are writable.
[PASS] The public image directory and its content are writable.
[PASS] The logs directory and its content are writable.
[PASS] GD or Imagick extension is installed.
[PASS] Intl extension is installed.
[PASS] Mbstring extension is installed.

Config files

[PASS] The application config file is present
[PASS] The passbolt config file is present

Core config

[PASS] Debug mode is off.
[PASS] Cache is working.
[PASS] Unique value set for security.salt
[PASS] Full base url is set to
[PASS] App.fullBaseUrl validation OK.
[PASS] /healthcheck/status is reachable.

SSL Certificate

[FAIL] SSL peer certificate does not validate
[FAIL] Hostname does not match when validating certificates.
[WARN] Using a self-signed certificate
[HELP] fopen(): Peer certificate CN=test-' did not match expected
fopen(): Failed to enable crypto
#fopen(:// failed to open stream: operation failed


[PASS] The application is able to connect to the database
[PASS] 19 tables found
[PASS] Some default content is present
[PASS] The database schema up to date.

GPG Configuration

[PASS] PHP GPG Module is installed and loaded.
[PASS] The server gpg key is not the default one
[PASS] The environment variable GNUPGHOME is set to /home/www-data/.gnupg.
[PASS] The directory /home/www-data/.gnupg containing the keyring is writable by the webserver user.
[PASS] The public key file is defined in config/passbolt.php and readable.
[PASS] The private key file is defined in config/passbolt.php and readable.
[PASS] The server key fingerprint matches the one defined in config/passbolt.php.
[PASS] The server public key defined in the config/passbolt.php is in the keyring.
[PASS] There is a valid email id defined for the server key.
[PASS] The public key can be used to encrypt a message.
[PASS] The public key can be used to sign a message.
[PASS] The public key can be used to encrypt and sign a message.
[PASS] The private key can be used to decrypt a message.
[PASS] The private key can be used to decrypt and verify a message.
[PASS] The public key can be used to verify a signature.

Application configuration

[PASS] Using latest passbolt version (2.0.1).
[PASS] Passbolt is configured to force SSL use.
[PASS] App.fullBaseUrl is set to HTTPS.
[PASS] Selenium API endpoints are disabled.
[PASS] Search engine robots are told not to index content.
[PASS] Registration is closed, only administrators can add users.
[PASS] Serving the compiled version of the javascript app
[PASS] All email notifications will be sent.

2 error(s) found. Hang in there!

  • the SQL-Error-Log is empty
  • email-log of passbolt is empty
  • the debug-mode is enabled in config/passbolt.php, but it does not generate any output - where is the data gathered by debug stored? email.log?

Any help is highly appreciated.
Thank you & keep up the nice work. We all like the project and are looking forward to any progress.

Can you check the charset in your database? See. Error 500 when try to recover account after upgrade to v2.0.1

We’re working on a hotfix to help with the migration.

My mysql says
InnoDB utf8mb4_unicode_ci 464 KiB 0 B

Which would be ok?

Can you check the individual fields for the table file_storage?

File_storage seems to be empty:

(sorry it is german :slight_smile: )


Hope I got the correct info :slight_smile:

Yes so it’s the same problem, you need to change the “Koallation” following the method described in the other ticket. Error 500 when try to recover account after upgrade to v2.0.1

I just got it right. It was indeed solved by altering the fields to utf8. THanks for your fast support!

I have one other issue, also directly related to the update:

I can’t edit/copy password-entries over the gui. If I mark a PW-Entry the fields for edit, copy, share are still greyed out.

For entries that have been in the system prior to update to v2 edit / sharing, etc. is possible.

@jay1984 I think there might be some issues with the record created in the meantime, they might be corrupted. Could you try to create a new one now and see if the same error occurs? For the passwords created in the meantime you might have to delete / create them again. It’s not possible, can contact us at could schedule a call to see if they can be recovered.

I just added a new entry. Unfortunately it is still the same issue. No edit, copy, etc. is possible when I select the new entry. The fields for edit, etc. are still not accessible

If you have time now, we could organize a quick call.
Send us an email to

Can you check if the permissions table or any other have this collate issue.
We’re working on a fix right now, it would help us a lot.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.