New install - Redirected to login

Hi everyone! :slight_smile:

I just installed passbolt latest version (2.0.7) into my server and everything went ok but when I try to login I got redirected to the login page again (tried both Chrome and Firefox and both Linux and MacOS), the brower extension version is 2.0.10.

It is a clean install and I have created the admin user without any problem. Also the install is under a subdomain, not a subfolder, and got SSL with Let’s encrypt.

My machine is using Centos 7.5 with a CPanel running both Apache 2.4 & Nginx 1.14. Also PHP 7.1.18 and MariaDB 10.2.15.

I checked the logs and they are empty, also checked twice for file permissions and session gets created on /var folder.

The only error I found out is in the Chrome extension under console:
vendors.min.js:82340 GET https://URL_HERE/auth/checkSession.json?api-version=v1 403 ()

Here is my healthcheck:

 Healthcheck shell       
---------------------------------------------------------------

 Environment

 [PASS] PHP version 7.1.18.
 [PASS] PCRE compiled with unicode support.
 [PASS] The temporary directory and its content are writable.
 [PASS] The public image directory and its content are writable.
 [PASS] The logs directory and its content are writable.
 [PASS] GD or Imagick extension is installed.
 [PASS] Intl extension is installed.
 [PASS] Mbstring extension is installed.

 Config files

 [PASS] The application config file is present
 [PASS] The passbolt config file is present

 Core config

 [PASS] Debug mode is off.
 [PASS] Cache is working.
 [PASS] Unique value set for security.salt
 [PASS] Full base url is set to https://accounts.bigmomo.com
 [PASS] App.fullBaseUrl validation OK.
 [PASS] /healthcheck/status is reachable.

 SSL Certificate

 [PASS] SSL peer certificate validates
 [PASS] Hostname is matching in SSL certificate.
 [PASS] Not using a self-signed certificate

 Database

 [PASS] The application is able to connect to the database
 [PASS] 18 tables found
 [PASS] Some default content is present
 [PASS] The database schema up to date.

 GPG Configuration

 [PASS] PHP GPG Module is installed and loaded.
 [PASS] The server gpg key is not the default one
 [PASS] The environment variable GNUPGHOME is set to /home/bigmomo/.gnupg.
 [PASS] The directory /home/bigmomo/.gnupg containing the keyring is writable by the webserver user.
 [PASS] The public key file is defined in config/passbolt.php and readable.
 [PASS] The private key file is defined in config/passbolt.php and readable.
 [PASS] The server key fingerprint matches the one defined in config/passbolt.php.
 [PASS] The server public key defined in the config/passbolt.php is in the keyring.
 [PASS] There is a valid email id defined for the server key.
 [PASS] The public key can be used to encrypt a message.
 [PASS] The public key can be used to sign a message.
 [PASS] The public key can be used to encrypt and sign a message.
 [PASS] The private key can be used to decrypt a message.
 [PASS] The private key can be used to decrypt and verify a message.
 [PASS] The public key can be used to verify a signature.

 Application configuration

 [PASS] Using latest passbolt version (2.0.7).
 [PASS] Passbolt is configured to force SSL use.
 [PASS] App.fullBaseUrl is set to HTTPS.
 [PASS] Selenium API endpoints are disabled.
 [PASS] Search engine robots are told not to index content.
 [PASS] Registration is closed, only administrators can add users.
 [PASS] Serving the compiled version of the javascript app
 [PASS] All email notifications will be sent.

 No error found. Nice one sparky!

X-Powered-By: PHP/7.1.18
Content-type: text/html; charset=UTF-8

Hi @bigmomo,

This could be an issue with sessions or cookies, for example if you have 3rd party cookies disabled in your browser. https://github.com/passbolt/passbolt_api/issues/177

Hi @remy and thanks for your answer!

I tried this (with both Firefox and Chrome) and still the same. Also added the domain as an Allow to Exceptions in both browsers but I still get redirected :frowning:

Firefox:
image

Chrome:
image

I just found out the Session file in the server has this inside:
Config|a:1:{s:4:"time";i:1528447633;}Flash|a:1:{s:5:"flash";a:1:{i:0;a:4:{s:7:"message";s:47:"You are not authorized to access that location.";s:3:"key";s:5:"flash";s:7:"element";s:11:"Flash/error";s:6:"params";a:1:{s:5:"class";s:5:"error";}}}}

That’s normal, that’s what triggers the login.

That’s basically telling us that even though the login was successful the log in state is not carried forward.
Can you check if there are any errors on you SELinux logs? Maybe also check how sessions are configured, there might be some issues with how CPanel are defined them and how passbolt is setup to use them.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.