Passbolt using PostgreSQL

This post is to help development in Passbolt using PostgreSQL as a database.
Please list your installation and issues, if any. PostgreSQL is still experimental.

  1. Passbolt version = ;
  2. PHP version = ;
  3. Docker (Yes) or (No) = ;
  4. Server (Nginx, etc) = ;
  5. Mail Server = ;
  6. OS = ;
  7. Working (Yes) or (No) = ;


Does your issue show any error in Passbolt log:

  1. Passbolt version = 3.6 CE;
  2. PHP version = 7.4;
  3. Docker (Yes) or (No) = No;
  4. Server (Nginx, etc) = Nginx;
  5. Mail Server = Postfix;
  6. OS = Ubuntu 20.04;
  7. Working (Yes) or (No) = Yes;

Issues: I can not add a user avatar to any account, avatar says saved. The android app does not allow me to add new passwords (maybe an app issue and not PostgreSQL).

Does your issue show any error in Passbolt log: There are no errors in the logs.

I think PostgreSQL support works great except for the 2 issues I am having. The two issue are not critical to me. I would say Passbolt supports PostgreSQL 99%, grade “A”.

Hi @Duffman, thank you for creating this thread.

Regarding your avatar problem, can you check the allow_url_fopen php value and give us the output of this command:

sudo grep -rn allow_url_fopen /etc/php/

It should return:

/etc/php/7.4/fpm/php.ini:857:allow_url_fopen = On
/etc/php/7.4/cli/php.ini:857:allow_url_fopen = On

You should have some logs on /var/log/php7.4-fpm.log too.

For Android, can you enable debug logs, reproduce the problem and send us logs ?


1 Like


my php7.4-fpm shows open.

nothing in php7.4-fpm log. status and journal are clear of errors.

i am just a noobie so i am probably wrong on my comments below :grin:.

i am thinking it is an issue of the database storing the images. utf8 vs uft8mb4. is utf8 text only?

i think i read that mariadb stores the images after Passbolt v3.4, maybe it was v3.5.

below is from

"The default Passbolt files are made for MySQL/MariaDB, which has two UTF-8 encoding formats:

  • utf8: incomplete UTF-8 support
  • utf8mb4: full UTF-8 support

By default, Passbolt uses utf8mb4. However, in PostgreSQL, there’s only one UTF8 format, namely utf8."

Thank you for all your help. I really enjoy Passbolt!!!



Hi Bill,

I followed the LinuxBabe tutorial to setup passbolt with postgresql on Ubuntu 22.04 and I got the same issue than you, no avatar:

By inspecting the browser logging console, I can see the avatar got 404 not found.

If you followed the same tutorial than me, you have this section in your /etc/nginx/conf.d/passbolt.conf:

     # A long browser cache lifetime can speed up repeat visits to your page
  location ~* \.(jpg|jpeg|gif|png|webp|svg|woff|woff2|ttf|css|js|ico|xml)$ {
       access_log        off;
       log_not_found     off;
       expires           360d;

Remove this section from your nginx configuration file, then restart nginx:

sudo systemctl restart nginx

You should see your avatar now \0/

Let me know if it works for you :wink:


1 Like


You are 100% correct. i am never right on my guess of what is wrong :sweat_smile: :rofl:
Thank you so much!!!
Works perfect!!!
A ++
I now have avatars!!!
I can see you are a great webmaster, Thank you for your time and help :grinning:

i would say Passbolt postgreSQL is working 100%.

Passbolt is amazing!!!


Great, thank you for your feedback and your happiness :hugs:
Enjoy your passbolt instance and don’t hesitate if you have further questions.

Best regards,

1 Like