Problem finishing install on Ubuntu 22.04.2 LTS

I installed a fresh new ubuntu with the latest Server-ISO available at ubuntu dot com.
It’s Version 22.04.2 LTS.

I was able to download every file and as well had successfull installed all components and created the database user and password.

unlucky it say go to the ip-adress from the server and start configure it.
this does not work because it’s showing me the standard nginx screen but no passbolt installation.

with /install added it won’t work either.

I’m currently not a pro at Ubuntu but basics i can do.

If you need some more informations please ask me and provide some command for it.



I have read intro post: About the Installation Issues category
I have read the tutorials, help and searched for similar issues
I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck
I describe the steps I have taken to trouble shoot the problem
I describe the steps on how to reproduce the issue

Hi @wdwc Welcome to the forum!

Can you verify which installation guide you were following? And, which step specifically is where you are having a problem?


Thank you, for your answer.

I followed this guide:

Problem occurs at step Open Passbolt after installation over hostname or ip address.

It‘s just showing me the standard nginx page.


Could you post the contents of your /etc/passbolt/passbolt.php file? Make sure to clear out the passwords though!

Usually there is a misconfiguration when you just get the nginx page

Hi @clayton

Thank You for your respond!

Actually i’m only having some passbolt.default.php and default.php but no passbolt.php.

Here are the pictures from default.php, I’ll wasn’t able to copy text out of the ssh.
I’ll think something gone wong at installation, because youre saying that i’m supposed to have some passbolt.php file.

By the way, I’m using some virtualised vm ware ubuntu server …
Here are the complete VM WARE Folder, Username and Passwort are “passbolt”.
I’m currently only try it out because I’m searching for some good solution for my passwords, what is bether then the current one. ZIP-File is downloadable here: 1.91 GB file on MEGA

Thank You!

Few may want to click on those links. :grin:

Just paste the photo into the post.

The passbolt.php is created as a copy of passbolt.default.php during the setup and populated with the provided settings you gave.

okay …

picture 1

and picture nr. 2

i dont have any passbolt.php actually in the folder you named.

You can create one:

cd /etc/passbolt
cp passbolt.default.php passbolt.php


This i’m done.
Nothing changed.

sudo apt remove passbolt-ce-server and sudo apt install passbolt-ce-server nothing chaged. file still exists.


I just checked the ISO package list again to make sure it didn’t include NGINX or Mariadb and it doesn’t. The reason I checked is because passbolt installs these in the process.

To start fresh and get rid of installed files you would want to:

sudo apt purge mariadb-server
sudo apt purge nginx
sudo apt purge passbolt-ce-server
sudo apt autoclean
sudo apt autoremove

Try that, reboot, then start the install process again.

Thank You garrett.

I’m done this, it hasn’t worked. I still don’t got some passbolt.php at /etc/passbolt.

I’m pretty surprised that this is isn’t working fine.


I can try to reproduce, thanks for posting results.

no problems, if you need anything else, let me know.

Hi @wdwc ,

The /etc/passbolt/passbolt.php configuration file is generated during the web setup process.

If you see the default nginx page and not the web setup page, it is expected the file is missing.

Can you check on your server the /etc/nginx/sites-enabled path content ?

I guess there is both default.conf and nginx-passbolt.conf files.

You can delete the default.conf file (it is why you have the default nginx page displayed) and let the passbolt conf file.

Then reload nginx:

sudo systemctl reload nginx

You should be able to see the web wizard and finish the setup process.


I just installed Ubuntu22.04 minimized on Virtualbox 7 and was able to get to this point here:


I have Port Forwarding on VBOX set from local to remote
I am accessing with a Windows machine and set u22passbolt.local in my hosts file.

However, without SSL, the gpg_key step would not proceed. @clayton Is this normal?

I then created a self-signed SSL cert and key via Passbolt Help | Manual HTTPS configuration on Debian and Ubuntu with user provided certificates

I created a second Port Forwarding on VBOX to go from local 4430 to remote 443. But Firefox wasn’t happy so I switched to Chrome.

In Chrome:

Gpg_key step proceeded quickly.

After patiently waiting on Binary Things happening step it was successful:

Contents of /etc/passbolt:


Yes, with deleting “default” it show’s me the installation process.
There was at the Folder /etc/nginx/sites-enabled some default and nginx-passbolt.conf.

with deleting default it worked.

by the way i’m using vmware not virtualbox :slight_smile:

And it works on VirtualBox too! I didn’t think vmware was the problem, so I just used what I had installed already. Thanks for reporting the success!