Problem on Debian 11.3

Hi guys,

I just installed passbolt on Debian v.11.3

Almost all work fine except I can’t reach some pages:
On the sign in page, if I click to “change user”, the page is blank.

Same thing for the Admin page.

When I execute the healthcheck command, I have only 2 errors:
[FAIL] Passbolt is not configured to force SSL use.
[FAIL] App.fullBaseUrl is not set to HTTPS.

I don’t need SSL because I will only use passbolt for intern use.

It works only with Chrome.
With Edge and Firefox, all pages are blank

Thanks in advance for yours answers.

Hi @Dabertch If you want to provide more details feel free, but what catches my eye is the /passbolt/ in the url path. If you remove that and it works, you might to check your web server routing settings.

What installation guide did you follow? Are you wanting the path to include /passbolt/?

Hi @garrett, Thank you for your answer.
If I type only the ip address it’s not working. I reach the welcome page of Apache.

In my passbolt.php file, I set my welcome page to http://ipadress/passbolt. So it works like it should.
Here is my intstallation guide: Installing Passbolt on Linux (Debian 10)

Could you tell me which linux distribution and which passbolt version should I use to be sure Passbolt works perfectly ? It’s ok if I need to create a new VM and I’m sure it works.
Because I think the issue is either the version of debian or passbolt.

@Dabertch Thanks for the info. Official guides are here Passbolt Help | Installation

The good news is it works with many flavors! After walking through the official guide check back.

Also, for Apache see the “install from source” section for directions. All other installs assume NGINX.

I’ve tried to follow the tutorial for Debian yesterday but it didn’t work.

Downloading dependencies was failed… I dont’ know if I did something wrong…

Hi @Dabertch,

You are trying to use passbolt in a subfolder /passbolt, I guess there is a missing /base parameter in your passbolt.php configuration file, as @garrett spoted:

return [

    /**
     * DEFAULT APP CONFIGURATION
     *
     * All the information in this section must be provided in order for passbolt to work
     * This configuration overrides the CakePHP defaults locating in app.php
     * Do not edit app.php as it may break your upgrade process
     */
    'App' => [
        // A base URL to use for absolute links.
        // The fully qualified domain name (including protocol) to your application’s root
        // e.g. where the passbolt instance will be reachable to your end users.
        // This information is need to render images in emails for example.
        'fullBaseUrl' => 'http://192.168.66.53',
        // OPTIONAL you can specify the base directory the app resides in
        // usefull for example if you are running passbolt in a subdirectory like localhost/passbolt
        // Ensure your string starts with a / and does NOT end with a /
        'base' => '/passbolt'
    ],
(etc etc etc)

Our dependencies installation script assumes you are installing passbolt on a vanilla server. Which errors did you encounter ? What is the error message ?

As it seems you have other website installed aside passbolt on your server, can you share the Apache virtualhost you created for passbolt ?

Another tip, as explained in this page, you can install passbolt without the nginx dependency (and using apache) with this command:

sudo DEBIAN_FRONTEND=noninteractive apt-get install \
  --no-install-recommends passbolt-ce-server

Cheers,

1 Like

Hi @_jc
Thank you a lot ! I’ve changed /base and all work properly !

Thank you to you two for your help !

My problem is solved :slight_smile:

1 Like

Wow, it is great news :+1: Enjoy your passbolt instance and don’t hesitate if you have further questions.

Best,

@_jc Link to change user in the sign page doesn’t work. When I click on it, I go to the the “lost my password” page… Maybe the translation in french doesn’t fit ??

Hi,

It is normal. You can have only one user configured with the passbolt browser extension.
If you want to switch to another user, you have to enter your email, wait one minute to receive the email, click on the link to recover your account, and put your private key.
Passbolt extension can manage only one private key at once.

You can know more about the extension on this page: Passbolt Help | Why do I need a browser extension?

Best,

Ok Thank You !
So now for sure all work fine !

1 Like