Solved: Loading, please wait and 503 for roles.json due to connection limiter

I just installed using git and healthcheck is fine, but I’m getting intermittent “loading, please wait” after logins.

The Chrome browser console is reporting:

Failed to load resource: the server responded with a status of 503 ()


Uncaught (in promise) u

I’ve cleared cookies, the extension works fine…but login to the landing page is mostly miss and sometimes hit. The second error of “uncaught (in promise)” shows when successfully hitting the resource page.

ADDED EDIT: If I check “disable cache” in the browser it will load. When I uncheck disable cache and subsequently refresh the page it will not load.
CORRECTION: Sometimes it will still not load even with browser cache disabled.

Any idea what this is related to?

I would check with your hosting provider, to my knowledge passbolt doesn’t return 503 “service unavailable” but rather 500 if something internally is wrong. My best guess at this stage would be a service in front of passbolt that is acting up. Do you have any more detail about the reponse from the server? Or log on the server itself?

Passbolt, especially when loading, is not handling very well this type of situation where some requests but not all fail.

1 Like

Okay I just found an Nginx-related connection limiter. It was set to 3 per IP address. I changed it to 10. Working okay now! Thanks @remy