URL is redirecting but unable to get the UI

I installed passbolt on an Ubuntu server; when I access the URL, it redirects to the auth/login page, but the UI does not load(http://publicip/auth/login?redirect=%2F), updated basepathurl in passbolt.php, tried installing ssl with manual and none as well facing same issue with both and also tried to install using the docker this is also a same issue, attached below screenshot, for the reference

→ URL accessing

waiting for the early response !! Thanks

Hi @Krithi ,

Can you connect to your server and try to perform a

sudo su -s /bin/bash -c "/usr/share/php/passbolt/bin/cake passbolt healthcheck" www-data

output of su -s /bin/bash -c “/usr/share/php/passbolt/bin/cake passbolt healthcheck” www-data attached below in the screenshot

Hi @Krithi,

Couple of questions:

  • It was an existing ubuntu server? 22.04?
  • Did you follow this guide: Passbolt Help | Install Passbolt CE on Ubuntu 22.04 (I would say yes since I see the path /usr/share/php/passbolt in the message that you shared, but just to be sure)
  • Does the DB server is on the same machine?
  • If not does the ubuntu server can communicate to the DB server?

Let’s try first to fix the link between passbolt and db server.


Hi max,

  • It was an existing ubuntu server? 22.04?

  • Did you follow this guide: [Passbolt Help | Install Passbolt CE on Ubuntu 22.04]
    (Passbolt Help | Install Passbolt CE on Ubuntu 22.04) (I would say yes since I see the path /usr/share/php/passbolt in the message that you shared, but just to be sure)

  • Does the DB server is on the same machine?
    yes on the same machine

  • If not does the ubuntu server can communicate to the DB server?

It was an existing ubuntu server? 22.04?

Server is created on aws ec2, fresh instance

can you check inside your /etc/passbolt/passbolt.php the database settings, something seems off

Hi Max,

Thanks for the help!! Really Appreciate,
I have attached the passbolt.php file below for your reference

 * Passbolt ~ Open source password manager for teams
 * Copyright (c) Passbolt SA (https://www.passbolt.com)
 * Licensed under GNU Affero General Public License version 3 of the or any later version.
 * For full copyright and license information, please see the LICENSE.txt
 * Redistributions of files must retain the above copyright notice.
 * @copyright     Copyright (c) Passbolt SA (https://www.passbolt.com)
 * @license       https://opensource.org/licenses/AGPL-3.0 AGPL License
 * @link          https://www.passbolt.com Passbolt(tm)
 * @since         2.0.0
 * By default passbolt try to use the environment variables or fallback on the default values as
 * defined in default.php. You can use passbolt.default.php as a basis to set your own configuration
 * without using environment variables.
 * 1. copy/paste passbolt.default.php to passbolt.php
 * 2. set the variables in the App section
 * 3. set the variables in the passbolt section
 * To see all available options, you can refer to the default.php file, and modify passsbolt.php accordingly.
 * Do not modify default.php or you may break your upgrade process.
 * Read more about how to install passbolt: https://www.passbolt.com/help/tech/install
 * Any issue, check out our FAQ: https://www.passbolt.com/faq
 * An installation issue? Ask for help to the community: https://community.passbolt.com/
return [

     * All the information in this section must be provided in order for passbolt to work
     * This configuration overrides the CakePHP defaults locating in app.php
     * Do not edit app.php as it may break your upgrade process
    'App' => [
        // A base URL to use for absolute links.
        // The fully qualified domain name (including protocol) to your application’s root
        // e.g. where the passbolt instance will be reachable to your end users.
        // This information is need to render images in emails for example.
        'fullBaseUrl' => '',
        // OPTIONAL you can specify the base directory the app resides in
        // usefull for example if you are running passbolt in a subdirectory like localhost/passbolt
        // Ensure your string starts with a / and does NOT end with a /
        // 'base' => '/subdir'

    // Database configuration.
    'Datasources' => [
        'default' => [
            'host' => 'localhost',
            //'port' => 'non_standard_port_number',
            'username' => 'user',
            'password' => 'secret',
            'database' => 'passbolt',

    // Email configuration.
    'EmailTransport' => [
        'default' => [
            'host' => 'localhost',
            'port' => 25,
            'username' => 'user',
            'password' => 'secret',
            // Is this a secure connection? true if yes, null if no.
            'tls' => null,
            //'timeout' => 30,
            //'client' => null,
            //'url' => null,
    'Email' => [
        'default' => [
            // Defines the default name and email of the sender of the emails.
            'from' => ['passbolt@your_organization.com' => 'Passbolt'],
            //'charset' => 'utf-8',
            //'headerCharset' => 'utf-8',

     * This is the default configuration.
     * It enforces the use of ssl, and does not provide a default OpenPGP key.
     * If your objective is to try passbolt quickly for evaluation purpose, and security is not important
     * you can use the demo config example provided in the next section below.
    'passbolt' => [
        // GPG Configuration.
        // The keyring must to be owned and accessible by the webserver user.
        // Example: www-data user on Debian
         'gpg' => [
            // Tell GPG where to find the keyring.
            // If putenv is set to false, gnupg will use the default path ~/.gnupg.
            // For example :
            // - Apache on Centos it would be in '/usr/share/httpd/.gnupg'
            // - Apache on Debian it would be in '/var/www/.gnupg'
            // - Nginx on Centos it would be in '/var/lib/nginx/.gnupg'
            // - etc.
            //'keyring' => getenv("HOME") . DS . '.gnupg',
            // Replace GNUPGHOME with above value even if it is set.
            //'putenv' => false,

            // Main server key.
           'serverKey' => [
                // Server private key fingerprint.
               'fingerprint' => '',
                //'public' => CONFIG . 'gpg' . DS . 'serverkey.asc',
                //'private' => CONFIG . 'gpg' . DS . 'serverkey_private.asc',

 * Uncomment the lines below if you want to try passbolt quickly.
 * and if you are not concerned about the security of your installation.
 * (Don't forget to comment the default config above).
 //   'debug' => true,
  //  'passbolt' => [
   //     'registration' => [
    //        'public' => true
//      ],
 //       'ssl' => [
  //         'force' => false,
   //     ],
    //   'gpg' => [
//             'serverKey' => [
//                     'fingerprint' => '2FC8945833C51946E937F9FED47B0811573EE67E',
 //               'public' => CONFIG . DS . 'gpg' . DS . 'unsecure.key',
//              'private' => CONFIG . DS . 'gpg' . DS . 'unsecure_private.key',   
//             ],
 //     ],
  // ]


Hi max,

Attached Scrrenshot below for thye reference, i changed only the basepath url

Continuation of passbolt.php file screenshot

Continuation of passbolt.php file screenshot

@Krithi It suggests the user and password fields for the database did not get populated with the credentials you provided during setup. Please change those in passbolt.php and see what happens.

Hi garrette,

I have updated the db details and reloaded nginx still the ui is in pending status to load, if you have the detailed steps, please share it wil me i will try from my side, as of now i referred

// Database configuration.
‘Datasources’ => [
‘default’ => [
‘host’ => ‘localhost’,
//‘port’ => ‘non_standard_port_number’,
‘username’ => ‘passboltadmin’,
‘password’ => ‘*****’,
‘database’ => ‘passboltdb’,

@Krithi Does the Healthcheck run now?

Hi garrett,

I have attached the screenshot below for healthcheck!!
as of now i am not using ssl as of now none option used

@Krithi The forum site is blocking some of your posts because of the repeated links to your ip - just an FYI. Thanks for the screenshots.

The expected installation flow goes

  1. install the package
  2. answer the configuration questions as part of the package install (this establishes a database, with credentials, and gets the databases squared away)
  3. navigate to the website

Some of the errors shown are simply because step 3 has not yet happened. But, as there was a problem in Step 2 which we are sorting through, I think the next step should be to run the command shown in the next-to-last line in your first of the two screenshots you just posted - regarding the migrations. This should get the tables in place.

Then try to access the site again.

(Also, if you want to copy/paste using Ubuntu desktop command line, use Ctrl+Shift+C. Ctrl+C is cancel)


Do we need install db manually ?
Eg:apt-get install mysql-service ??

@Krithi It would normally install mariadb. If mysql -V is not showing it is installed then yes, it would need to be installed.

@garrett @max

I am getting as below attached screenshot in the UI, Any idea on this