"Use on this Page" not saving URI

I’m a fresh user of Passbolt (from KeePass v2) using the Amazon AWS EC2 package (Debian 11, 4.1.1-1, PHP 8.2.7), routed through Cloudflare on my own domain.

Initially I had some issues getting it to work with SSL but managed to solve this and so far the app, with its limitations, appears to work just fine in the Chrome extension.

However, one thing I noticed is that the automatic password fill doesn’t appear to function at all; if I reach a login page (e.g. https://www.sandbox.game/en/sign/?redirectTo=%2Fen%2F&createAccount=false ) and click the Passbolt icon in the login fields I can create/search for a matching account (see 1st screenshot).
If I then proceed to search and select the right account I press the “Use on this page” button and it fills the login data into the correct fields. (see 2nd screenshot)

It doesn’t remember that the entry belongs to this website and I’m required to search it up every single time I visit. Am I missing something obvious? Shouldn’t the “Use on this Page” button add the URI to the entry for future page visits?

If the functionality I expected is not what it actually does, is there a way to add the URL quickly other than going to the full Passbolt website, logging in, finding the entry, and pasting the URL?

I’d be grateful for any assistance.

Healthcheck, 2 fails

// Executed for www-data


[PASS] PHP version 8.2.7.
[PASS] PCRE compiled with unicode support.
[PASS] The temporary directory and its content are writable and not executable.
[PASS] The logs directory and its content are writable.
[PASS] GD or Imagick extension is installed.
[PASS] Intl extension is installed.
[PASS] Mbstring extension is installed.

Config files

[PASS] The application config file is present
[PASS] The passbolt config file is present

Core config

[PASS] Debug mode is off.
[PASS] Cache is working.
[PASS] Unique value set for security.salt
[PASS] Full base url is set to https://this.is.correct
[PASS] App.fullBaseUrl validation OK.
[FAIL] Could not reach the /healthcheck/status with the url specified in App.fullBaseUrl
[HELP] Check that the domain name is correct in /etc/passbolt/passbolt.php
[HELP] Check the network settings

SSL Certificate

[PASS] SSL peer certificate validates
[PASS] Hostname is matching in SSL certificate.
[PASS] Not using a self-signed certificate


[PASS] The application is able to connect to the database
[PASS] 32 tables found
[PASS] Some default content is present
[PASS] The database schema up to date.

GPG Configuration

[PASS] PHP GPG Module is installed and loaded.
[PASS] The environment variable GNUPGHOME is set to /var/lib/passbolt/.gnupg.
[PASS] The directory /var/lib/passbolt/.gnupg containing the keyring is writable by the webserver user.
[PASS] The server OpenPGP key is not the default one
[PASS] The public key file is defined in /etc/passbolt/passbolt.php and readable.
[PASS] The private key file is defined in /etc/passbolt/passbolt.php and readable.
[PASS] The server key fingerprint matches the one defined in /etc/passbolt/passbolt.php.
[PASS] The server public key defined in the /etc/passbolt/passbolt.php (or environment variables) is in the keyring.
[PASS] There is a valid email id defined for the server key.
[PASS] The public key can be used to encrypt a message.
[PASS] The private key can be used to sign a message.
[PASS] The public and private keys can be used to encrypt and sign a message.
[PASS] The private key can be used to decrypt a message.
[PASS] The private key can be used to decrypt and verify a message.
[PASS] The public key can be used to verify a signature.
[PASS] The server public key format is Gopengpg compatible.
[PASS] The server private key format is Gopengpg compatible.

Application configuration

[FAIL] This installation is not up to date. Currently using 4.1.1 and it should be 4.1.2.
[HELP] See. Passbolt Help | Update
[PASS] Passbolt is configured to force SSL use.
[PASS] App.fullBaseUrl is set to HTTPS.
[PASS] Selenium API endpoints are disabled.
[PASS] Search engine robots are told not to index content.
[INFO] The Self Registration plugin is enabled.
[INFO] Registration is closed, only administrators can add users.
[PASS] The deprecated self registration public setting was not found in /etc/passbolt/passbolt.php.
[WARN] Host availability checking is disabled.
[HELP] Make sure this instance is not publicly available on the internet.
[HELP] Or set the PASSBOLT_EMAIL_VALIDATE_MX environment variable to true.
[HELP] Or set passbolt.email.validate.mx to true in /etc/passbolt/passbolt.php.
[PASS] Serving the compiled version of the javascript app.
[WARN] Some email notifications are disabled by the administrator.

JWT Authentication

[PASS] The JWT Authentication plugin is enabled
[PASS] The /etc/passbolt/jwt/ directory is not writable.
[PASS] A valid JWT key pair was found

SMTP Settings

[PASS] The SMTP Settings plugin is enabled.
[PASS] SMTP Settings coherent. You may send a test email to validate them.
[PASS] The SMTP Settings source is: database.
[WARN] The SMTP Settings plugin endpoints are enabled.
[HELP] It is recommended to disable the plugin endpoints.
[HELP] Or set passbolt.security.smtpSettings.endpointsDisabled to true in /etc/passbolt/passbolt.php.

[FAIL] 2 error(s) found. Hang in there!




Hello @BentoFox

I have tried to reproduce and the autofill from this specific login page seems to work, however in the screenshot I can see that the url is empty. Could you add the url to the resource and see if you are able to automatically fill the field afterward?

Hey @antony , thanks for the quick response.
It does work if I add the URL manually to the entry in the main passbolt page.

Is it an issue because I imported these logins from KeePass
or does the browser extension “Use on this page” button not do what I assumed it would? (Storing the URL in the entry when pressing ‘Use on this page’ so it remembers in the future).

Ideally, I’d not want to manually enter URLs for every existing entry as I have quite a few of those freshly imported.

That’s completely understandable.

After you removed any sensitive information, could you share with us the header of the exported csv from KeePass v2 ? Ideally, if you can also add an example based on one of your rows with dummy data (e.g. https://url.com, resource1, password1 etc.) it’d be highly appreciated.

Hello Kevin, the button “Use on this page” doesn’t save automatically the URL in the resource.
The button was built just to use the password on the website you are on.
You can save the URL field manually on the Passbolt website or create one from the extension, which will detect the URL where you are visiting from the extension.
If you imported from KeePass and you have the URLs on your passwords, should be imported. Please help Antony providing any information to check if it is failing to be able to correct it.,
Thank you!

1 Like

Heya, it appears there is no issue at all then. The import did not go wrong, many of the entries simply didn’t have the URL set in KeePass.

However, KeePass (mobile) had a popup asking to store the URL in the entry if the URL or App-ID wasn’t stored yet when you used the password entry on that page or app, which I found very useful; and I blindly assumed Passbolt had this functionality. :slight_smile:

TLDR: Looks like there is no issue. The feature I thought wasn’t functioning actually doesn’t exist in the first place. I look forward to see the Tool continue to develop though, as I realize I may have joined quite early in the roadmap. Sorry for the confusion and thanks a ton for clarifying :+1:

1 Like