User is unable to fetch the passwords

I have configured passbolt on Ubuntu 20.4. Now one of the user is unable to fetch the passwords but as he is administrator user, he is able to see all the users but no passwords are visible.

Hi @sayujya,

Do you (or another member of your team) have shared passwords with this new user ? Even if he is administrator, he won’t be able to see any password if they are not shared with him.

Cheers,

It is already a old user and many passwords are shared with him. This is a sudden issue

In your screenshot, it seems the page is not fully loaded yet, because of the loading bar at the bottom:

Does this loading bar finished to load ? Does this user changed his private key ? Which action has been performed before it was broken ?

This loading bar is not completed. Also, we tried to clear cache from the browser, removed extension and re-installed. Also, I cleared cache from the server end also but no luck

Thanks for the informations, can you have a look at nginx error logs in /var/log/nginx directory and passbolt error log /var/log/passbolt/error.log if there is any error logged ?

Thanks !

nope nothing is much logged except authentication is required. Which is I guess basic error logged.

Can you enable debug logs of the passbolt extension ?

If you are using Google Chrome can you please go to: chrome://extensions

  • Activate the Developer mode in the top right corner
  • Look for the Passbolt card and click details button
  • Look for the Inspect views and the index.html link
  • A new window will appear this is the debugger of the browser extension << very important, we need logs from this other window
  • Go to network tab
  • Try to reproduce the error

On Firefox, you can go to: about:debugging#/runtime/this-firefox

  • locate Passbolt and click Inspect
  • A new tab for the console of the browser extension will appear.
  • Go to the network tab
  • try to reproduce the error

Do you see any error in the extension debug window ?

Hi @sayujya ,

Another thoughts, you can launch a cleanup command:

sudo -H -u www-data bash -c "/usr/share/php/passbolt/bin/cake passbolt cleanup"

If it still doesn’t work, can you post the full output of this command:

sudo /usr/share/php/passbolt/bin/status-report

Thanks,

This worked thankyou so much!! Also one more issue I have… As you can see that I am getting unsafe mode in the page because my SSL is set to false and the URL is also “http://…”. When I set force SSL to true and enter “https://…” in the URL, the web page does not work.

1 Like

If you move from http to https, you have to edit the fullBaseUrl parameter in your /etc/passbolt/psssbolt.php and set https instead of http.

(...)
return [
    'App' => [
        // A base URL to use for absolute links.
        // The url where the passbolt instance will be reachable to your end users.
        // This information is need to render images in emails for example
        'fullBaseUrl' => 'https://your.passbolt.url',
    ],
(...)

If you are changing your domain from HTTP to HTTPS , you will unlink the browser extension of all the users. Before changing the domain, you must ensure that all the users have a copy of their private key to recover their account .

Cheers,

I have changed the fullBaseUrl from http to https but it didn’t worked and the site stopped loading. Now the scene is, Actually I have restored the backup from my old passbolt server to new passbolt server. Only the domain name was changed. Rest everything was as it is. I have configured nginx “Auto”. Also I have re-tried configuring nginx recently but it didn’t changed fullBaseURL to https. What can be the root cause?

HI,

The dpkg-reconfigure passbolt-ce-server reconfigure nginx server but don’t modify /etc/passbolt/passbolt.php configuration file, you have to do it manually.

And if the site stops loading, you can find the reason in /var/log/nginx log files and /var/log/passbolt/error.log

Cheers,

Okay thanks! What if I delete the lest’s encrpyt files and certificates and reconfigure the nginx with dpkg-reconfigure passbolt-ce-server? Will that solve??

I have tried above things but it is not solving this… It remains http only. Also, one more thing I noticed is that when I change the fullBaseURL to https, the passbolt healthcheck commands starts to work slow and gives the error of cannot contact passbolt healthcheck something.

Yes, you can delete /etc/letsencrypt files, they will be regenerated.

Maybe do you have a firewall on your server ? Can you post the full output with the error message ?

Best,

That is a EC2 server. Do I need to allow any ports from there?

Hi,

I’m pretty sure port 443 is closed.
If I request your website with http, it works:

$ curl -I http://pbl.saleshandyteam.com/
HTTP/1.1 404 Not Found
Server: nginx/1.18.0 (Ubuntu)
Date: Thu, 10 Feb 2022 18:08:35 GMT
Content-Type: text/html; charset=UTF-8
Connection: keep-alive
Keep-Alive: timeout=5
strict-transport-security: max-age=31536000; includeSubDomains
Content-Security-Policy: default-src 'self'; script-src 'self'; style-src 'self' 'unsafe-inline'; img-src 'self';frame-src 'self';

But with https, I get a timeout. you have to allow traffic from 443 port, somewhere on EC2 console :stuck_out_tongue:

Oh yes!!! HAHA thanks @_jc it is solved! :smile:

1 Like