[v2.0.0-rc1] That version of GPGAuth is not supported

Hello everyone.
I’m trying out the Version2 and got this error. I’ll tried to install it multiple times and tried to upgrade my passbolt v1. Everytime the same error and when I’ll try to recover my account on Firefox the Browser show me a dead bird after entering my username.

pecl means I’m using the newest gpg
I’m trying to use passbolt on Debian 9 with PHP 7.0.

Here is my healthcheck

/ __ ____ _____ / / ____ / / /
/ /
/ / __ `/ / / __ / __ / / _/
/ / // ( |
) /
/ / /
/ / / /
/ _

Open source password manager for teams

Healthcheck shell…


e[32m[PASS]e[0m PHP version 7.0.19-1
e[32m[PASS]e[0m PCRE compiled with unicode support
e[32m[PASS]e[0m The temporary directory and its content are writable
e[32m[PASS]e[0m The public image directory and its content are writable
e[32m[PASS]e[0m The logs directory and its content are writable

Config files

e[32m[PASS]e[0m The application config file is present
e[32m[PASS]e[0m The passbolt config file is present

Core config

e[32m[PASS]e[0m Debug mode is off.
e[32m[PASS]e[0m Cache is working.
e[32m[PASS]e[0m Unique value set for security.salt
e[32m[PASS]e[0m Full base url is set to https://auth.fbit.cloud
e[32m[PASS]e[0m App.fullBaseUrl validation OK.
e[32m[PASS]e[0m /healthcheck/status is reachable.

SSL Certificate

e[32m[PASS]e[0m SSL peer certificate validates
e[32m[PASS]e[0m Hostname is matching in SSL certificate.
e[32m[PASS]e[0m Not using a self-signed certificate


e[32m[PASS]e[0m The application is able to connect to the database
e[32m[PASS]e[0m 18 tables found
e[32m[PASS]e[0m Some default content is present
e[32m[PASS]e[0m The database schema up to date.

GPG Configuration

e[32m[PASS]e[0m PHP GPG Module is installed and loaded.
e[32m[PASS]e[0m The server gpg key is not the default one
e[32m[PASS]e[0m The environment variable GNUPGHOME is set to /home/www-data/.gnupg.
e[32m[PASS]e[0m The directory /home/www-data/.gnupg containing the keyring is writable by the webserver user.
e[32m[PASS]e[0m The public key file is defined in config/passbolt.php and readable.
e[32m[PASS]e[0m The private key file is defined in config/passbolt.php and readable.
e[32m[PASS]e[0m The server key fingerprint matches the one defined in config/passbolt.php.
e[32m[PASS]e[0m The server key defined in the config/passbolt.php is in the keyring.
e[32m[PASS]e[0m There is a valid email id defined for the server key.
e[32m[PASS]e[0m The public key can be used to encrypt and sign a message.
e[32m[PASS]e[0m The private key can be used to decrypt a message.

Application configuration

e[32m[PASS]e[0m Using latest passbolt version (2.0.0-rc.1).
e[32m[PASS]e[0m Passbolt is configured to force SSL use.
e[32m[PASS]e[0m App.fullBaseUrl is set to HTTPS.
e[32m[PASS]e[0m Selenium API endpoints are disabled.
e[32m[PASS]e[0m Search engine robots are told not to index content.
e[32m[PASS]e[0m Registration is closed, only administrators can add users.
e[32m[PASS]e[0m Serving the compiled version of the javascript app
e[32m[PASS]e[0m All email notifications will be sent.

e[32mNo error found. Nice one sparky!e[0m

I don’t know how to use the preformated Text feature here ^^’

Hello @RogueThorn,

Thanks for trying out the RC, it’s very much appreciated.

Healtcheck is all green, could you copy/paste some logs here ?

  • cakephp log : logs/error.log
  • firefox browser log : from the keyboard: press Ctrl+Shift+J (or Cmd+Shift+J on a Mac).


2018-01-15 18:17:43 Error: [Imagine\Exception\RuntimeException] Gd not installed
Request URL: /auth/verify.json

oh ^^’ php-gd is missing. After installing php-gd everything seems to work.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.