100% Proxy issue, can't figure it out. Stuck on "Installing composer"

For reference, after going mad, I ran the installation on a fresh Centos7 VM on my HyperV environment with a switch connected to my pc’s network which doesn’t use any proxy etc. worked flawlessly. I will call this the ClientInstall & all urls have a space after // due to 2 links restriction…

The problem I’m experiencing is that during the setup on the real server (vm) (Will call this ServerInstall) The installation gets stuck on “Installing composer”

Both ServerInstall and ClientInstall uses the same .iso, both fresh install. The ServerInstall is behind a proxy if we want to access the internet. I’m 110% if not 200% certain the installation fails due to the proxy not being set somewhere. Have I missed to set it somewhere? Current setup:

(Note ip obfuscated)

  1. export http_proxy=http://
  2. export https_proxy=http://
  3. Added “PROXY=http://” in /etc/yum.conf
  4. pear config-set http_proxy http://
  5. git config --global --add http.proxy http://
  6. git config --global --add https.proxy http://

Trying to connect to to mariadb with provided credentials…

Cloning into ‘/var/www/passbolt’…
remote: Enumerating objects: 891, done.
remote: Counting objects: 100% (891/891), done.
remote: Compressing objects: 100% (723/723), done.
remote: Total 891 (delta 310), reused 461 (delta 123), pack-reused 0
Receiving objects: 100% (891/891), 3.17 MiB | 0 bytes/s, done.
Resolving deltas: 100% (310/310), done.

Installing composer…

PHP 7.3.18 (cli) (built: May 12 2020 08:04:33) ( NTS )
passbolt: latest
OS: CentOS Linux 7 (Core) / CentOS-7-x86_64-DVD-2003

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.