Android App Mobile Setup - Barcode

Trying to setup the Android mobile app to connect to Passbolt CE. I’ve had this working in the past.

Browser access works as intended.

I’m receiving errors on both Chrome/Firefox while scanning the barcode for initial setup, with the browser stating that “There was an issue during the transfer. Please try again later or contact your administrator.”, and then asks me to restart the process. The app appears to think that the transfer was successful and states “Your information has been transferred!”

I have TOTP, Duo MFA, and Yubikey OTP setup and enabled on my profile and all work via browser. Could this be some of my issue?

Edge/Chrome Error

Edge/Chrome - Stack

Error: Unsupported status
at $r.getUpdatedTransfer (chrome-extension://ljeppgjhohmhpbdhjjjbiflabdgfkhpo/webAccessibleResources/js/dist/app.js:2:553555)

Error below is Firefox generated

No data available.Message

Unsupported status



I have read intro post: About the Installation Issues category
I have read the tutorials, help and searched for similar issues
I provide relevant information about my server (component names and versions, etc.)
Ubuntu Server 22.04.3
Nginx 1.18.0
php 8.1.2
mysql 8.0.34
I provide a copy of my logs and healthcheck
I describe the steps I have taken to trouble shoot the problem
I describe the steps on how to reproduce the issue


[PASS] PHP version 8.1.2-1ubuntu2.14.
[PASS] PCRE compiled with unicode support.
[PASS] The temporary directory and its content are writable and not executable.
[PASS] The logs directory and its content are writable.
[PASS] GD or Imagick extension is installed.
[PASS] Intl extension is installed.
[PASS] Mbstring extension is installed.

Config files

[PASS] The application config file is present
[PASS] The passbolt config file is present

Core config

[PASS] Debug mode is off.
[PASS] Cache is working.
[PASS] Unique value set for security.salt
[PASS] Full base url is set to https://passbolt.****************.com
[PASS] App.fullBaseUrl validation OK.
[PASS] /healthcheck/status is reachable.

SSL Certificate

[PASS] SSL peer certificate validates
[PASS] Hostname is matching in SSL certificate.
[PASS] Not using a self-signed certificate


[PASS] The application is able to connect to the database
[PASS] 32 tables found
[PASS] Some default content is present
[PASS] The database schema up to date.

GPG Configuration

[PASS] PHP GPG Module is installed and loaded.
[PASS] The environment variable GNUPGHOME is set to /var/lib/passbolt/.gnupg.
[PASS] The directory /var/lib/passbolt/.gnupg containing the keyring is writable by the webserver user.
[PASS] The server OpenPGP key is not the default one
[PASS] The public key file is defined in /etc/passbolt/passbolt.php and readable.
[PASS] The private key file is defined in /etc/passbolt/passbolt.php and readable.
[PASS] The server key fingerprint matches the one defined in /etc/passbolt/passbolt.php.
[PASS] The server public key defined in the /etc/passbolt/passbolt.php (or environment variables) is in the keyring.
[PASS] There is a valid email id defined for the server key.
[PASS] The public key can be used to encrypt a message.
[PASS] The private key can be used to sign a message.
[PASS] The public and private keys can be used to encrypt and sign a message.
[PASS] The private key can be used to decrypt a message.
[PASS] The private key can be used to decrypt and verify a message.
[PASS] The public key can be used to verify a signature.
[PASS] The server public key format is Gopengpg compatible.
[PASS] The server private key format is Gopengpg compatible.

Application configuration

[PASS] Using latest passbolt version (4.3.0).
[PASS] Passbolt is configured to force SSL use.
[PASS] App.fullBaseUrl is set to HTTPS.
[PASS] Selenium API endpoints are disabled.
[PASS] Search engine robots are told not to index content.
[INFO] The Self Registration plugin is enabled.
[INFO] Registration is closed, only administrators can add users.
[WARN] The deprecated self registration public setting was found in /etc/passbolt/passbolt.php.
[HELP] You may remove the “passbolt.registration.public” setting.
[WARN] Host availability checking is disabled.
[HELP] Make sure this instance is not publicly available on the internet.
[HELP] Or set the PASSBOLT_EMAIL_VALIDATE_MX environment variable to true.
[HELP] Or set to true in /etc/passbolt/passbolt.php.
[PASS] Serving the compiled version of the javascript app.
[WARN] Some email notifications are disabled by the administrator.

JWT Authentication

[PASS] The JWT Authentication plugin is enabled
[PASS] The /etc/passbolt/jwt/ directory is not writable.
[PASS] A valid JWT key pair was found

SMTP Settings

[PASS] The SMTP Settings plugin is enabled.
[PASS] SMTP Settings coherent. You may send a test email to validate them.
[PASS] The SMTP Settings source is: database.
[WARN] The SMTP Settings plugin endpoints are enabled.
[HELP] It is recommended to disable the plugin endpoints.
[HELP] Or set to true in /etc/passbolt/passbolt.php.

[PASS] No error found. Nice one sparky!

Hello @pattonjo,

Indeed, regarding the error you have here:

It’s a bug from the browser extension that should be fixed on the incoming version 4.4.0 of the browser extension. However, if we are talking about the same bug, the browser extension shows an error message but on the mobile, the transfer should be completed and working. Do you confirm it’s working on the mobile despite the error message on the browser extension?


The browser states that an error has occurred and attempts to restart the barcode scanning process.

The mobile app says that the process has been completed and states "Your information has been transferred!”, so initially it looks like it’s working, but it does not work.

Are you using MFA? If so, which provider are you using? (YubiKey, TOTP, Duo)

Can you share the logs of the mobile app?
On the top right corner there is a question mark button to extract the log

I have this same issue with my iOS deployment and have worked with Support. They tell me its “a known issue that has been discovered a few days ago” and that they are working to resolve it in the next release.

I have the same situation with our deployment but I managed to get the passbolt app to work . When I continue in the app after the error in the browser, I can input the passphrase and even create passwords and then see them in the web version.

@antony @max

Sorry for the delay. Went in today to go through the exact same process and to get you logs.

I still get the following in browser:

“The browser states that an error has occurred and attempts to restart the barcode scanning process.”

Except this time, I enter my pass phrase into the mobile app and am greeted with different options for authenticating. I’m in and the mobile app is currently functional.

I have TOTP, Duo MFA, and Yubikey OTP setup and enabled on my Passbolt profile.

It looks as though there has been an update to the Android mobile app since starting this thread, and my issues appear to have been resolved, less the browser error stated above, which has already been identified as a bug and is slated to be resolved.