Beginner Needing Help with Passbolt Setup on Debian 12

[ x] I have read intro post: About the Installation Issues category
[x ] I have read the tutorials, help and searched for similar issues
[ x] I provide relevant information about my server (component names and versions, etc.)
[x ] I provide a copy of my logs and healthcheck
[x ] I describe the steps I have taken to trouble shoot the problem
[x ] I describe the steps on how to reproduce the issue

Hi everyone,

I am a complete beginner and I have been following a tutorial for setting up Passbolt on Debian 12. I am having trouble accessing the Passbolt web page, and I am not sure what commands to use to diagnose and show my issue properly.

Here are some details about my setup:

  • I do not have a domain name or SSL certificate yet.
  • I configured Nginx to run in “none” mode and used my server’s IP address.
  • I have modified the Nginx configuration to not use SSL since I do not have a certificate.

I have tried to remove the SSL directive from the configuration, but I’m still having issues.

Could someone please guide me on how to correctly set up Nginx for Passbolt without SSL for now and how to properly diagnose and show any issues?

Thank you so much for your help!

Hello @Woofy1, welcome to the forum :wink:

I’m not sure that I completely understand the issues here, you’ve followed our dedicated documentation and after configuring NGINX you don’t know how to access the instance? If so, have you seen something like this:

But with http://YOUR_IP_ADDRESS ? Have you tried to navigate to this URL to access the installation wizard?

If you already installed it via the installation wizard, you can run:
sudo su -s /bin/bash -c "/usr/share/php/passbolt/bin/cake passbolt healthcheck" www-data to diagnose any installation issues.

Also, if you’ve done any manual iteration on nginx, have you tried to reload nginx? sudo systemctl reload nginx

I have tried navigating to http://YOUR_IP_ADDRESS but I am unable to access the installation wizard. I followed the documentation and configured NGINX, but I still can’t access the Passbolt instance.

I also ran the command you provided

I have tried reloading NGINX with sudo systemctl reload nginx multiple time but the issue persists