Cannot login with fresh install

[x] I have read intro post: About the Installation Issues category
[x] I have read the tutorials, help and searched for similar issues
[x] I provide relevant information about my server (component names and versions, etc.)
[ ] I provide a copy of my logs and healthcheck
[x] I describe the steps I have taken to trouble shoot the problem
[ ] I describe the steps on how to reproduce the issue

Hi, I’ve just freshly installed Passbolt with Docker on my Synology DS1515+ NAS.
Installation was successful and I also created admin user. Everything went fine till the very last step.
Once I try to login to my new account, then Passbolt won’t let me in. I can see the cog-wheel for a while, but after that simply nothing happens, no error message, no warning, it just doesn’t log in.

Reading some other forum topics I saw that it might happen if the time zone of the server and on the client is different. Well, I realized that the Docker container must have different timezone than the client, because all the time stamps on the log file show 1 hour difference comparing to the client time.

The strange thing is that the system time on the NAS is equal to my local time, as well as my client time and also the Docker’s local time. (I can see that from the log file of Docker.) Apparently only Passbold container is one hour behind.
Unfortunately I didn’t find any way to set the time in a Docker container, and I suppose also Passbolt doesn’t provide such a setting.

Might be my login issue related to the time zone issue indeed? If yes, then how can I solve it? If not possible to solve the time zone issue, then how can I log in?

By the way, on the Synology NAS there is php 5.6 installed, HTTP back-end server is Apache 2.2. Operating system is DSM 6.2.

I’ll really appreciate any help and idea!

I found the solution. I set two environment variables and restarted the container:
TZ: Europe/Amsterdam

Even though the log file still have different time stamps from my local time, finally I can login and Passbolt works fine. :slight_smile:

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.