Can't navigate to site once installed

Hi all,

This is the second time I have tried to install Passbolt and keep getting stuck at the same issue. Everything seems to be set up properly but right now I am just getting the Apache default page. I am pretty confident it has to do with my apache setup (I am fairly new to web servers) but I do already have another website up and running on my local network so I know the web server is setup at least somewhat properly. My other site running on the server is http as well. The first time I did the installation I was able to get to the plugin page by forcing my url to /index.php but have not been able to do that with this second try which gives me a “requested url not found” error. I followed the Debian 9 install guide.

I am using an Apache web server on Ubuntu 16.04. My database is setup on a separate server than the web server. I am including my health check, site-available conf file, passbolt.php file (The relevant parts at least).

Here is my health check
www-data@localhost:~/passbolt$ ./bin/cake passbolt healthcheck

     ____                  __          ____
    / __ \____  _____ ____/ /_  ____  / / /_
   / /_/ / __ `/ ___/ ___/ __ \/ __ \/ / __/
  / ____/ /_/ (__  |__  ) /_/ / /_/ / / /
 /_/    \__,_/____/____/_.___/\____/_/\__/

 Open source password manager for teams
 Healthcheck shell


 [PASS] PHP version
 [PASS] PCRE compiled with unicode support.
 [PASS] The temporary directory and its content are writable.
 [PASS] The public image directory and its content are writable.
 [PASS] The logs directory and its content are writable.
 [PASS] GD or Imagick extension is installed.
 [PASS] Intl extension is installed.
 [PASS] Mbstring extension is installed.

 Config files

 [PASS] The application config file is present
 [PASS] The passbolt config file is present

 Core config

 [PASS] Debug mode is off.
 [PASS] Cache is working.
 [PASS] Unique value set for security.salt
 [PASS] Full base url is set to
 [PASS] App.fullBaseUrl validation OK.
 [FAIL] Could not reach the /healthcheck/status with the url specified in App.fullBaseUrl
  [HELP] Check that the domain name is correct in config/passbolt.php
  [HELP] Check the network settings

 SSL Certificate

 [FAIL] SSL peer certificate does not validate
 [FAIL] Hostname does not match when validating certificates.
 [WARN] Using a self-signed certificate


 [PASS] The application is able to connect to the database
 [PASS] 18 tables found
 [PASS] Some default content is present
 [PASS] The database schema up to date.

 GPG Configuration

 [PASS] PHP GPG Module is installed and loaded.
 [PASS] The server gpg key is not the default one
 [PASS] The environment variable GNUPGHOME is set to /var/www/.gnupg.
 [PASS] The directory /var/www/.gnupg containing the keyring is writable by the webserver user.
 [PASS] The public key file is defined in config/passbolt.php and readable.
 [PASS] The private key file is defined in config/passbolt.php and readable.
 [PASS] The server key fingerprint matches the one defined in config/passbolt.php.
 [PASS] The server public key defined in the config/passbolt.php is in the keyring.
 [PASS] There is a valid email id defined for the server key.
 [PASS] The public key can be used to encrypt a message.
 [PASS] The private key can be used to sign a message.
 [PASS] The public and private keys can be used to encrypt and sign a message.
 [PASS] The private key can be used to decrypt a message.
 [PASS] The private key can be used to decrypt and verify a message.
 [PASS] The public key can be used to verify a signature.

 Application configuration

 [PASS] Using latest passbolt version (2.1.0).
 [FAIL] Passbot is not configured to force SSL use.
  [HELP] Set passbolt.ssl.force to true in config/passbolt.php.
 [FAIL] App.fullBaseUrl is not set to HTTPS.
  [HELP] Check App.fullBaseUrl url scheme in config/passbolt.php.
 [PASS] Selenium API endpoints are disabled.
 [PASS] Search engine robots are told not to index content.
 [PASS] Registration is closed, only administrators can add users.
 [PASS] Serving the compiled version of the javascript app
 [PASS] All email notifications will be sent.

5 error(s) found. Hang in there!

‘App’ => [
// A base URL to use for absolute links.
// The url where the passbolt instance will be reachable to your end users.
// This information is need to render images in emails for example
‘fullBaseUrl’ => ‘http:// passbolt. company. com’,

    // Database configuration.
    'Datasources' => [
        'default' => [
            'host' => 'Host_IP',
            //'port' => 'non_standard_port_number',
            'username' => 'passbolt',
            'password' => 'Password',
            'database' => 'passbolt',

    // Email configuration.
    'EmailTransport' => [
        'default' => [
            'host' => 'localhost',
            'port' => 25,
            'username' => 'user',
            'password' => 'secret',
            // Is this a secure connection? true if yes, null if no.
            'tls' => null,
            //'timeout' => 30,
            //'client' => null,
            //'url' => null,
    'Email' => [
        'default' => [
            // Defines the default name and email of the sender of the emails.
            'from' => ['' => 'Passbolt'],
            //'charset' => 'utf-8',
            //'headerCharset' => 'utf-8',

'passbolt' => [
        // GPG Configuration.
        // The keyring must to be owned and accessible by the webserver user.
        // Example: www-data user on Debian
        'ssl' => [
            'force' => false,
        'gpg' => [
            // Tell GPG where to find the keyring.
            // If putenv is set to false, gnupg will use the default path ~/.gnupg.
            // For example :
            // - Apache on Centos it would be in '/usr/share/httpd/.gnupg'
            // - Apache on Debian it would be in '/var/www/.gnupg'
            // - Nginx on Centos it would be in '/var/lib/nginx/.gnupg'
            // - etc.
            //'keyring' => getenv("HOME") . DS . '.gnupg',
            // Replace GNUPGHOME with above value even if it is set.
            //'putenv' => false,

            // Main server key.
            'serverKey' => [
                // Server private key fingerprint.
                'fingerprint' => 'BFB16DDEBD66416F45F9BF5DBAFB708A7B77F58A',
                //'public' => CONFIG . 'gpg' . DS . 'serverkey.asc',
                //'private' => CONFIG . 'gpg' . DS . 'serverkey_private.asc',

<VirtualHost *:80>
ServerName http:// passbolt. company. com
DocumentRoot /var/www/passbolt

    <Directory /var/www/passbolt>
        Options FollowSymLinks
        AllowOverride All
        Require all granted


Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0*               LISTEN      1527/mysqld
tcp        0      0    *               LISTEN      1217/sshd
tcp        0      0*               LISTEN      1553/postgres
tcp        0    480 10.x0.x8.x1:22        10.x0.x8.x1:60437     ESTABLISHED 2104/sshd: user1
tcp6       0      0 :::80                   :::*                    LISTEN      1561/apache2
tcp6       0      0 :::22                   :::*                    LISTEN      1217/sshd
tcp6       0      0 ::1:5432                :::*                    LISTEN      1553/postgres
tcp6       0      0 :::443                  :::*                    LISTEN      1561/apache2
udp        0      0    *                           981/dhclient
udp6       0      0 ::1:41058               ::1:41058               ESTABLISHED 1553/postgres

Not sure where to turn to now. Let me know if any other files are need or any other information. Thanks in advance!

*Edit: I added the spaces in the url because I am a new user. The real files do not have the spaces.

[x] I have read intro post: About the Installation Issues category
[x] I have read the tutorials, help and searched for similar issues
[x] I provide relevant information about my server (component names and versions, etc.)
[x] I provide a copy of my logs and healthcheck
[x] I describe the steps I have taken to trouble shoot the problem
[x] I describe the steps on how to reproduce the issue

Hello @jrik,

Is there also a sites-enabled/passbolt.conf?
Did you restart your apache ?


1 Like

Well this is embarrassing
 Haha thanks for the quick answer! Marking as solved.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.