CentOS 7 - Nginx Webserver not reachable

[X] I have read intro post: About the Installation Issues category
[X] I have read the tutorials, help and searched for similar issues
[ ] I provide relevant information about my server (component names and versions, etc.)
[ ] I provide a copy of my logs and healthcheck
[ ] I describe the steps I have taken to trouble shoot the problem
[ ] I describe the steps on how to reproduce the issue

I am not an experienced Linux user and I have trouble to get to the web setup for the CentOS 7 installation. I run some CentOS VMs which are working quite fine. I want to setup passbolt for a working scenario which is accessable outside my company network. Firewall should be configured correctly.
At first I installed an minimal iso of CentOS 7 (I installed it twice). I registered a dnss record for the IP and configured NAT. I tried to do a basic install with the script like provided in the guide and the installation does not seem to fail. After the the script I can not access the webserver.

I also tried to configure hosts like stated in this post --> Passbolt CE CentOS 7 cannot reach domain/ip
Somehow Nginx server does not seem to work or can be accessed.

Any ideas to get passbolt running with CentOS7?

  • I used a version of July I think. Do I need to update it first? (Sorry no expert)
  • I also tried to disable selinux with no success
  • Checking the status of Nginx show that it is up and running
  • As a test I tried the ubuntu installation (local only) which is working fine.

Hopefully somebody can point me to the right direction because I dont want use different Linux distributions.

Regrads from Germany

Hallo @slr, welcome to the forum!

Can you provide more information? Why do you think Nginx is not working? Error code? Describe what is happening and what you think should be happening.

Hello garrett,

the passbolt landing page is not loading. Also there is no “Welcome Page” of Nginx when I go to the address. I am using a german browser but its translated like “Host is not responding”. I tried a local IP address in the installation script, my extrenal domain name etc.

The installation with ubuntu worked fine with the same parameters.

Logs for Nginx are found /var/log/nginx/access.log and error.log. If there is no welcome to Nginx page (and we expect passbolt though sometimes files get crossed), there should be an error noted.

The logs should also confirm url activity.

There are no errors noted in both logs. It seems the webserver is not accessible and not reachable? SELiux problem maybe?

Current version of CentOS 7 is 1810 minimal.

Maybe the firewall is not open?

sudo firewall-cmd --permanent --zone=public --add-service=http
sudo firewall-cmd --permanent --zone=public --add-service=https
sudo firewall-cmd --reload

Thank you very much garrett! It was the firewall! I am no Linux expert but maybe you should add this for the CentOS 7 installation help. :slight_smile:


Yes, that’s a good suggestion! Glad it worked!

EDIT: I see it’s on the issues list here: https://github.com/passbolt/passbolt_install_scripts/issues/6

ok, i didnt look for a solution on github. Maybe you also add this information on the first topic here in installation issues.

I believed it’s listed now because of being solved.

Thanks guys I’ll try to add this to the install scripts when I have some bandwidth.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.

Hi everyone I added the code from @garrett to the install scripts hopefully will be merged this week. Thanks garrett I mentioned you on the commit and will add your email if you want to the release notes.

Yes, that’s a nice gesture! I’m good with that. Thanks @diego

1 Like