Configuration link redirects to wrong site, "welcome to nginx" debian 10 (Buster)

Hello everybody!
I have a problem so I hope someone here can help me for sure!

I have followed tutorial on:


and as opposed to the tutorial the link at the end of the installation sends me to the nginx site
instead of the passbolt configuration page

the page looks similar to this:

Welcome to nginx!

If you see this page, the nginx web server is successfully installed and working. Further configuration is required.

For online documentation and support please refer to nginx . org
Commercial support is available at nginx . com

Thank you for using nginx.

Please, do you have any idea how to fix this?
I need to have access from remote host. It should open Passbolt webapage, not NGINX page.
i also saw another user have the same problem but i didnt see a reply
Thank you in advance.

Hi @fred,

Which hostname are you using to access the passbolt install? Is this hostname you are using the same you introduced during the setup process?

In order to check the hostname you introduced on the setup you can check on /etc/nginx/conf.d/passbolt.conf and look for the line that contains ‘server_name’

1 Like


i used the same hostname yes, but i also tried with ip but the result was the same
and in the file “/etc/nginx/conf.d/passbolt.conf”
the ‘server_name’ is shown as SERVER_NAME

Ouch! that is not expected.

That line should be something like:



server_name myipaddress;

This might be a bug on the installation scripts. I will file a bug and dig a bit on it.

1 Like

I added this bug
If you have any information on the context of your setup like the steps to reproduce (special characters on the hostname, etc) feel free to add them on the issue I created.

1 Like

thank you for the quick reply

there was no special steps to encounter the issue i was following along with the guide and ran into the issue.
I hope it’s not just a mistake on my end

Thanks! I’ll look into it.

In the meantime, have you had your issue fixed by manually modifying the passbolt.conf nginx file as suggested?

1 Like

thank you for the support
no i have not tried but i will give it a closer look

this is the person with the similar problem (though discussion is closed)

1 Like

I messaged that user but they never responded:

Your nginx configuration is pointing to the default index.html file that is probably at /var/www/html/index.html

You need to change your nginx configuration file. Here’s mine:

server {
        listen 80;
        server_name     passbolt.YOURDOMAIN. COM;
        return 301 https://passbolt.YOURDOMAIN. COM;

server {
    listen 443 ssl http2;
    server_name passbolt.YOURDOMAIN. COM;

    root /var/www/passbolt/webroot;
    index index.php;

    client_body_buffer_size     100K;
    client_header_buffer_size   1k;
    client_max_body_size        5M;

    client_body_timeout   10;
    client_header_timeout 10;
    keepalive_timeout     5 5;
    send_timeout          10;
    ssl on;
    ssl_certificate     YOUR LOCATION OF FULLCHAIN;
    ssl_certificate_key YOUR LOCATION OF PRIVATE KEY;
    ssl_protocols TLSv1.2 TLSv1.3;
    ssl_prefer_server_ciphers on;
    ssl_session_tickets off;

    location / {
            try_files $uri $uri/ /index.php?$args;

    location ~ \.php$ {
            try_files                $uri =404;
            include                  fastcgi_params;
            fastcgi_pass   ;
            fastcgi_index            index.php;
            fastcgi_intercept_errors on;
            fastcgi_split_path_info  ^(.+\.php)(/.+)$;
            fastcgi_param            SCRIPT_FILENAME $document_root$fastcgi_script_name;
            fastcgi_param            SERVER_NAME $http_host;
            fastcgi_param            PHP_VALUE "upload_max_filesize=5M post_max_size=5M";




thank you for the support

I will try changing my file, i’ll report how it goes

EDIT: yes my file has had a couple of errors and fixing the code, fixed the issue
also tried on a new vm and it worked so it wasnt a big deal

a big thank you to everyone

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.