Connection to Mysql not possible

Hi everybody,

a few days ago I had a problem with setting up my ssl because I wasnt able anymore to login into my passbolt. Well, this time I am also not able to login into my passbolt and I get following error:

An internal error occurred. The server response could not be parsed. Please contact your administrator.

When logging into the server through remote I get the message, that there were over 50k unsuccessful login attempts . Is somebody trying to brute force into the system?

Last failed login: Sun Jul 17 12:23:22 UTC 2022 from on ssh:notty
There were 55220 failed login attempts since the last successful login.

Running the healthcheck runs immediately into an error.

   ____                  __          ____  
    / __ \____  _____ ____/ /_  ____  / / /_ 
   / /_/ / __ `/ ___/ ___/ __ \/ __ \/ / __/ 
  / ____/ /_/ (__  |__  ) /_/ / /_/ / / /    
 /_/    \__,_/____/____/_.___/\____/_/\__/   

 Open source password manager for teams
 Healthcheck shell.....Notice Error: Undefined index: message
In [/usr/share/php/passbolt/src/Utility/Healthchecks/DatabaseHealthchecks.php, line 72]

2022-07-17 12:37:38 notice: Notice (8): Undefined index: message in [/usr/share/php/passbolt/src/Utility/Healthchecks/DatabaseHealthchecks.php, line 72]
Exception: Connection to Mysql could not be established: SQLSTATE[HY000] [2002] Connection refused
In [/usr/share/php/passbolt/vendor/cakephp/cakephp/src/Database/Driver.php, line 133]

So I guess my questions are: Is the reason why I cant login into passbolt because of the many unsuccessfully attempts and therefore the database shutting down or is it something else?

I am running a small VLinux with CentOS 7 64bit, 1 vCPU and 2 GB of RAM.

I have read intro post: About the Installation Issues category
I have read the tutorials, help and searched for similar issues
I provide relevant information about my server (component names and versions, etc.)
I provide a copy of my logs and healthcheck
I describe the steps I have taken to trouble shoot the problem
I describe the steps on how to reproduce the issue

Hi @SgtFuturess the failed login attempts getting logged are most likely activity on port 22 ssh and I don’t think it reflects the issue with your db.

Regarding the error for the mysql connection being refused, it’s just a matter of connecting to the db.

Make sure the db user and password are correct in the Passbolt configuration. Attempt to connect manually to mysql to confirm credentials are correct, and that the mysql service is running.

Tried and worked and now I can access Passbolt once again :slight_smile: I dont know why such a step was necessary, I didnt change anything. I just started working again.